mail/exim - The NetBSD Packages Collection

The Exim mail transfer agent, a replacement for sendmail

Exim is a mail transport agent (MTA) developed at the University of Cambridge
for use on Unix systems connected to the Internet. It is freely available
under the terms of the GNU General Public Licence. In style it is similar to
Smail 3, but its facilities are more extensive, and in particular it has
options for verifying incoming sender and recipient addresses, for refusing
mail from specified hosts, networks, or senders, and for controlling mail
relaying.

This build of exim has the following non-default features enabled:

TRANSPORT_LMTP          SUPPORT_MAILDIR         SUPPORT_MAILSTORE
SUPPORT_MBX             AUTH_CRAM_MD5           AUTH_PLAINTEXT
AUTH_SPA                SUPPORT_TLS             USE_TCP_WRAPPERS

The following default feature is disabled by default, but may be enabled by
setting the 'exim-build-eximon' option:

EXIM_MONITOR

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 devel/pcre devel/pcre

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfexim-4.94.2nb2.tgz
NetBSD 8.0earmv7hfexim-4.94.2.tgz
NetBSD 8.0earmv7hfexim-4.94.2nb1.tgz
NetBSD 8.0i386exim-4.94.2.tgz
NetBSD 8.0i386exim-4.94.2nb1.tgz
NetBSD 8.0powerpcexim-4.94nb4.tgz
NetBSD 8.0powerpcexim-4.94.2nb1.tgz
NetBSD 8.0powerpcexim-4.94.2nb1.tgz
NetBSD 8.0powerpcexim-4.94.2nb2.tgz
NetBSD 8.0x86_64exim-4.94.2.tgz
NetBSD 8.0x86_64exim-4.94.2nb1.tgz
NetBSD 9.0aarch64exim-4.94.2nb2.tgz
NetBSD 9.0aarch64exim-4.94.2.tgz
NetBSD 9.0aarch64exim-4.94.2nb1.tgz
NetBSD 9.0alphaexim-4.94.2nb2.tgz
NetBSD 9.0alphaexim-4.94.2.tgz
NetBSD 9.0alphaexim-4.94nb4.tgz
NetBSD 9.0alphaexim-4.94.2nb1.tgz
NetBSD 9.0earmv6hfexim-4.94.2nb2.tgz
NetBSD 9.0earmv6hfexim-4.94.2.tgz
NetBSD 9.0earmv6hfexim-4.94.2nb1.tgz
NetBSD 9.0earmv7hfexim-4.94.2nb2.tgz
NetBSD 9.0earmv7hfexim-4.94.2.tgz
NetBSD 9.0earmv7hfexim-4.94.2nb1.tgz
NetBSD 9.0earmv7hfexim-4.94.2nb2.tgz
NetBSD 9.0i386exim-4.94.2.tgz
NetBSD 9.0i386exim-4.94.2nb1.tgz
NetBSD 9.0i386exim-4.94.2nb2.tgz
NetBSD 9.0m68kexim-4.94.2.tgz
NetBSD 9.0mips64ebexim-4.94.2nb1.tgz
NetBSD 9.0mips64ebexim-4.94nb3.tgz
NetBSD 9.0mips64ebexim-4.94nb4.tgz
NetBSD 9.0mips64ebexim-4.94nb4.tgz
NetBSD 9.0mips64ebexim-4.94.2nb2.tgz
NetBSD 9.0powerpcexim-4.94.2nb1.tgz
NetBSD 9.0powerpcexim-4.94.2.tgz
NetBSD 9.0powerpcexim-4.94nb4.tgz
NetBSD 9.0powerpcexim-4.94.2nb1.tgz
NetBSD 9.0powerpcexim-4.94.2nb2.tgz
NetBSD 9.0sparc64exim-4.94.2nb1.tgz
NetBSD 9.0sparc64exim-4.94.2.tgz
NetBSD 9.0sparc64exim-4.94nb4.tgz
NetBSD 9.0sparc64exim-4.94.2nb2.tgz
NetBSD 9.0sparcexim-4.94.2nb1.tgz
NetBSD 9.0sparcexim-4.94nb3.tgz
NetBSD 9.0sparcexim-4.94nb4.tgz
NetBSD 9.0sparcexim-4.94.2nb2.tgz
NetBSD 9.0vaxexim-4.94.2.tgz
NetBSD 9.0x86_64exim-4.94.2nb2.tgz
NetBSD 9.0x86_64exim-4.94.2nb2.tgz
NetBSD 9.0x86_64exim-4.94.2.tgz
NetBSD 9.0x86_64exim-4.94.2nb1.tgz
NetBSD 9.0x86_64exim-4.94.2nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

exim-appendfile-maildir
exim-appendfile-mailstore
exim-appendfile-mbx
exim-auth-dovecot
exim-build-eximon
Also build the X based exim queue monitoring tool.
exim-content-scan
Call virus and spam scanning direct from ACLs.
exim-lookup-cdb
Support mail account lookup via a Constant Data Base.
exim-lookup-dnsdb
Use DNS for lookups (as general database facility).
exim-lookup-dsearch
Lookup via key as filename in directory.
exim-lookup-ldap
LDAP lookup using a query in the form of a URL.
exim-lookup-mysql
Perform lookups in MySQL database.
exim-lookup-pgsql
Perform lookups in PostgreSQL database.
exim-lookup-redis
Support mail account lookup via a Redis database.
exim-lookup-sqlite
Perform lookups in SQLite database.
exim-lookup-whoson
Lookup in whoson dynamic IP address.
exim-old-demime
Use deprecated "demime" condition in the DATA ACL.
exim-router-iplookup
exim-tcp-wrappers
exim-tls
exim-transport-lmtp
gdbm
Use the GNU gdbm database library.
inet6
Enable support for IPv6.
opendmarc
readline
Enable use of GNU readline library.
saslauthd
Use the Cyrus saslauthd daemon for authentication.
spf
Enable Sender Policy Framework support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.