mail/akonadi - The NetBSD Packages Collection

The KDE PIM Storage Service

Akonadi is a new personal information management (PIM) framework for KDE 4 and
is set to be included in the 4.1 release. Akonadi will function as an extensible
data storage for all PIM applications. In KDE 3 all PIM applications had
different data storage and handling methods, which lead to several
implementations of essentially the same thing.  Besides data storage, Akonadi
has several other components including search, and a library (cache) for easy
access and notification of data changes.

Build dependencies

devel/automoc4 textproc/libxslt pkgtools/x11-links devel/boost-headers x11/xorgproto x11/xcb-proto x11/qt4-tools pkgtools/cwrappers x11/qt4-tools devel/cmake devel/pkgconf

Runtime dependencies

databases/shared-mime-info devel/boost-libs x11/qt4-libs x11/qt4-qdbus databases/shared-mime-info x11/qt4-libs x11/qt4-qdbus

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfakonadi-1.13.0nb39.tgz
NetBSD 8.0earmv7hfakonadi-1.13.0nb36.tgz
NetBSD 8.0earmv7hfakonadi-1.13.0nb38.tgz
NetBSD 8.0i386akonadi-1.13.0nb36.tgz
NetBSD 8.0i386akonadi-1.13.0nb38.tgz
NetBSD 8.0powerpcakonadi-1.13.0nb36.tgz
NetBSD 8.0powerpcakonadi-1.13.0nb38.tgz
NetBSD 8.0powerpcakonadi-1.13.0nb38.tgz
NetBSD 8.0powerpcakonadi-1.13.0nb39.tgz
NetBSD 8.0x86_64akonadi-1.13.0nb36.tgz
NetBSD 8.0x86_64akonadi-1.13.0nb38.tgz
NetBSD 9.0aarch64akonadi-1.13.0nb39.tgz
NetBSD 9.0aarch64akonadi-1.13.0nb36.tgz
NetBSD 9.0aarch64akonadi-1.13.0nb38.tgz
NetBSD 9.0alphaakonadi-1.13.0nb39.tgz
NetBSD 9.0earmv6hfakonadi-1.13.0nb39.tgz
NetBSD 9.0earmv6hfakonadi-1.13.0nb36.tgz
NetBSD 9.0earmv6hfakonadi-1.13.0nb38.tgz
NetBSD 9.0earmv7hfakonadi-1.13.0nb39.tgz
NetBSD 9.0earmv7hfakonadi-1.13.0nb36.tgz
NetBSD 9.0earmv7hfakonadi-1.13.0nb38.tgz
NetBSD 9.0earmv7hfakonadi-1.13.0nb39.tgz
NetBSD 9.0i386akonadi-1.13.0nb36.tgz
NetBSD 9.0i386akonadi-1.13.0nb38.tgz
NetBSD 9.0m68kakonadi-1.13.0nb34.tgz
NetBSD 9.0powerpcakonadi-1.13.0nb38.tgz
NetBSD 9.0powerpcakonadi-1.13.0nb36.tgz
NetBSD 9.0powerpcakonadi-1.13.0nb38.tgz
NetBSD 9.0powerpcakonadi-1.13.0nb39.tgz
NetBSD 9.0sparc64akonadi-1.13.0nb36.tgz
NetBSD 9.0sparc64akonadi-1.13.0nb39.tgz
NetBSD 9.0x86_64akonadi-1.13.0nb39.tgz
NetBSD 9.0x86_64akonadi-1.13.0nb39.tgz
NetBSD 9.0x86_64akonadi-1.13.0nb36.tgz
NetBSD 9.0x86_64akonadi-1.13.0nb38.tgz
NetBSD 9.0x86_64akonadi-1.13.0nb39.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

mysql
Enable MySQL support.
sqlite
Enable SQLite support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.