lang/swi-prolog-lite - The NetBSD Packages Collection

ISO/Edinburgh-style Prolog compiler

ISO/Edinburgh-style Prolog compiler.  Compliant with Part 1 of the ISO
standard for Prolog.  Covers all traditional Edinburgh Prolog features
and shares many features with Quintus and SICStus Prolog, including a
compatible module system. Very fast compiler, garbage collection (also
on atoms), fast and powerful C/C++ interface, autoloading,
GNU-readline interface.  SWI-Prolog supports architectures with 32-bit
or greater (64-bit) word-length.

This is the core package with basic SWI-Prolog packages.
X11 packages are available via swi-prolog-packages package.

Build dependencies

devel/cmake pkgtools/cwrappers

Runtime dependencies

shells/bash devel/gmp devel/ossp-uuid devel/readline devel/gmp devel/ossp-uuid devel/readline

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 8.0i386swi-prolog-lite-8.0.2nb2.tgz
NetBSD 8.0i386swi-prolog-lite-8.0.2nb2.tgz
NetBSD 8.0i386swi-prolog-lite-8.0.2nb2.tgz
NetBSD 8.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 8.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 8.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0aarch64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0aarch64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0aarch64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0alphaswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0alphaswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0alphaswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv6hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv6hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv6hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv7hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv7hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv7hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0earmv7hfswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0i386swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0i386swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0i386swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0m68kswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0m68kswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0mips64ebswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0mips64ebswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0mips64ebswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0mipselswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0mipselswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0mipselswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0sh3elswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0sh3elswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0sh3elswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0sparcswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0sparcswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0sparcswi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.0x86_64swi-prolog-lite-8.0.2nb2.tgz
NetBSD 9.99.96aarch64ebswi-prolog-lite-8.0.2nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.