lang/elk - The NetBSD Packages Collection

Embeddable Scheme interpreter

Elk is a Scheme interpreter intended to be used as a general, reusable
extension language subsystem for integration into existing and future
applications.  Elk can also be used as a stand-alone implementation of
the Scheme programming language.

One purpose of the Elk project is to end the recent proliferation of
mutually incompatible Lisp-like extension languages.  Instead of
inventing and implementing yet another extension language, application
programmers can integrate Elk into their application to make it
extensible and highly customizable.

Build dependencies

pkgtools/cwrappers devel/libtool-base

Runtime dependencies

databases/gdbm databases/gdbm

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 8.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 8.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 8.0i386elk-3.99.8nb3.tgz
NetBSD 8.0i386elk-3.99.8nb3.tgz
NetBSD 8.0powerpcelk-3.99.8nb3.tgz
NetBSD 8.0powerpcelk-3.99.8nb3.tgz
NetBSD 8.0powerpcelk-3.99.8nb3.tgz
NetBSD 8.0powerpcelk-3.99.8nb3.tgz
NetBSD 8.0x86_64elk-3.99.8nb3.tgz
NetBSD 8.0x86_64elk-3.99.8nb3.tgz
NetBSD 9.0aarch64elk-3.99.8nb3.tgz
NetBSD 9.0aarch64elk-3.99.8nb3.tgz
NetBSD 9.0aarch64elk-3.99.8nb3.tgz
NetBSD 9.0alphaelk-3.99.8nb3.tgz
NetBSD 9.0alphaelk-3.99.8nb3.tgz
NetBSD 9.0alphaelk-3.99.8nb3.tgz
NetBSD 9.0earmelk-3.99.8nb3.tgz
NetBSD 9.0earmelk-3.99.8nb3.tgz
NetBSD 9.0earmelk-3.99.8nb3.tgz
NetBSD 9.0earmv6hfelk-3.99.8nb3.tgz
NetBSD 9.0earmv6hfelk-3.99.8nb3.tgz
NetBSD 9.0earmv6hfelk-3.99.8nb3.tgz
NetBSD 9.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 9.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 9.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 9.0earmv7hfelk-3.99.8nb3.tgz
NetBSD 9.0i386elk-3.99.8nb3.tgz
NetBSD 9.0i386elk-3.99.8nb3.tgz
NetBSD 9.0i386elk-3.99.8nb3.tgz
NetBSD 9.0mips64ebelk-3.99.8nb3.tgz
NetBSD 9.0mips64ebelk-3.99.8nb3.tgz
NetBSD 9.0mips64ebelk-3.99.8nb3.tgz
NetBSD 9.0mips64ebelk-3.99.8nb3.tgz
NetBSD 9.0mips64ebelk-3.99.8nb3.tgz
NetBSD 9.0powerpcelk-3.99.8nb3.tgz
NetBSD 9.0powerpcelk-3.99.8nb3.tgz
NetBSD 9.0powerpcelk-3.99.8nb3.tgz
NetBSD 9.0powerpcelk-3.99.8nb3.tgz
NetBSD 9.0sh3elelk-3.99.8nb3.tgz
NetBSD 9.0sh3elelk-3.99.8nb3.tgz
NetBSD 9.0sh3elelk-3.99.8nb3.tgz
NetBSD 9.0sparc64elk-3.99.8nb3.tgz
NetBSD 9.0sparc64elk-3.99.8nb3.tgz
NetBSD 9.0sparc64elk-3.99.8nb3.tgz
NetBSD 9.0sparcelk-3.99.8nb3.tgz
NetBSD 9.0sparcelk-3.99.8nb3.tgz
NetBSD 9.0sparcelk-3.99.8nb3.tgz
NetBSD 9.0sparcelk-3.99.8nb3.tgz
NetBSD 9.0sparcelk-3.99.8nb3.tgz
NetBSD 9.0x86_64elk-3.99.8nb3.tgz
NetBSD 9.0x86_64elk-3.99.8nb3.tgz
NetBSD 9.0x86_64elk-3.99.8nb3.tgz
NetBSD 9.0x86_64elk-3.99.8nb3.tgz
NetBSD 9.0x86_64elk-3.99.8nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

motif
Enable motif support.
xaw
Enable Xaw support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.