games/cgoban-java - The NetBSD Packages Collection

Client for the KGS Go Server and SGF viewer/editor

CGoban-java (CGoban 3) is a port of the SGF editor of CGoban 1 to Java
combined with a client for the Kiseido Go Server.  It is missing the Go
Modem Protocol adapter from CGoban 1 and the IGS/NNGS client from cgoban
1, but the SGF editor is a bit better (and of course the KGS client in
it is much better than the IGS/NNGS client in CGoban 1).

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/openjdk11 lang/openjdk11

Binary packages

OSArchitectureVersion
NetBSD 8.0powerpccgoban-java-3.5.23.tgz
NetBSD 8.0powerpccgoban-java-3.5.23.tgz
NetBSD 8.0powerpccgoban-java-3.5.23.tgz
NetBSD 8.0powerpccgoban-java-3.5.23.tgz
NetBSD 9.0aarch64cgoban-java-3.5.23.tgz
NetBSD 9.0aarch64cgoban-java-3.5.23.tgz
NetBSD 9.0aarch64cgoban-java-3.5.23.tgz
NetBSD 9.0alphacgoban-java-3.5.23.tgz
NetBSD 9.0alphacgoban-java-3.5.23.tgz
NetBSD 9.0alphacgoban-java-3.5.23.tgz
NetBSD 9.0i386cgoban-java-3.5.23.tgz
NetBSD 9.0i386cgoban-java-3.5.23.tgz
NetBSD 9.0i386cgoban-java-3.5.23.tgz
NetBSD 9.0powerpccgoban-java-3.5.23.tgz
NetBSD 9.0powerpccgoban-java-3.5.23.tgz
NetBSD 9.0powerpccgoban-java-3.5.23.tgz
NetBSD 9.0powerpccgoban-java-3.5.23.tgz
NetBSD 9.0sparc64cgoban-java-3.5.23.tgz
NetBSD 9.0sparc64cgoban-java-3.5.23.tgz
NetBSD 9.0sparc64cgoban-java-3.5.23.tgz
NetBSD 9.0sparccgoban-java-3.4.14.tgz
NetBSD 9.0x86_64cgoban-java-3.5.23.tgz
NetBSD 9.0x86_64cgoban-java-3.5.23.tgz
NetBSD 9.0x86_64cgoban-java-3.5.23.tgz
NetBSD 9.0x86_64cgoban-java-3.5.23.tgz
NetBSD 9.0x86_64cgoban-java-3.5.23.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.