emulators/libretro-bsnes-mercury-performance - The NetBSD Packages Collection

Libretro core for SNES/Super Famicom emulation ("performance" profile)

Libretro is a simple but powerful development interface that allows for
the easy creation of emulators, games and multimedia applications that
can plug straight into any libretro-compatible frontend. This development
interface is open to others so that they can run these pluggable emulator
and game cores also in their own programs or devices.

bsnes/higan is a Super Nintendo Entertainment System / Super Famicom
video game system emulator that aims to document SNES/SFC hardware with
an extremely high degree of accuracy without compromise or optimisation.

bsnes-mercury is a fork of bsnes/higan aiming to restore some useful
features that have been removed, as well as improving performance
slightly. Maximum accuracy is still uncompromisable; anything that
affects accuracy is optional and off by default.

As such, it has quite high system requirements. For a SNES/SFC libretro
core that balances performance and accuracy to an acceptable level for
99% of games, consider using a snes9x core.

Three profiles are available: Performance, Balanced, and Accuracy.
Balanced is recommended for modern PCs. Use Accuracy for extreme cases
of hardware spec abuse (e.g. the game A.S.P. Air Strike Patrol).

Build dependencies

pkgtools/cwrappers devel/gmake

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0i386libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0i386libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0x86_64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 8.0x86_64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0aarch64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0aarch64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0aarch64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmlibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmlibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv6hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv6hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv6hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0earmv7hflibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0i386libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0i386libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0i386libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0powerpclibretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0x86_64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0x86_64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0x86_64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0x86_64libretro-bsnes-mercury-performance-20180803.tgz
NetBSD 9.0x86_64libretro-bsnes-mercury-performance-20180803.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.