editors/poedit - The NetBSD Packages Collection

Cross-platform gettext catalogs (.po files) editor

poEdit is a cross-platform gettext catalogs (.po files) editor.  It is built
with wxWindows toolkit and can run on any platform supported by it (although
it was tested only on Unix with GTK+ and Windows).  It aims to provide more
convenient approach to editing catalogs than launching vi and editing the
file by hand.

Here is a brief features list:

- User friendly way of editing entries. You can easily navigate in large
  catalogs, easily enter or modify entries (fuzzy flag is automatically
  removed if you change translation, you can copy original string to
  translation by pressing Alt-I)
- Whitespaces highlighting
- Fuzzy and untranslated records highlighting. Furthermore, untranslated
  and fuzzy translations are displayed at the top of the list
- Automatic compilation of .mo files (optional)
- Automatic headers update
- References browser lets you see where in what context the string is used
- You can use poEdit to scan source code for translatable strings
- Integration with KDE and GNOME desktops

Build dependencies

pkgtools/x11-links devel/boost-headers x11/xorgproto x11/xcb-proto devel/glib2-tools devel/gmake devel/pkgconf pkgtools/cwrappers

Runtime dependencies

archivers/zip devel/boost-libs textproc/gtkspell3 textproc/icu textproc/lucene++ x11/wxGTK30 sysutils/desktop-file-utils graphics/hicolor-icon-theme textproc/pugixml textproc/gtkspell3 textproc/icu x11/wxGTK30 sysutils/desktop-file-utils graphics/hicolor-icon-theme

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpoedit-2.3nb10.tgz
NetBSD 8.0i386poedit-2.3nb13.tgz
NetBSD 8.0i386poedit-2.3nb8.tgz
NetBSD 8.0i386poedit-2.3nb10.tgz
NetBSD 8.0i386poedit-2.3nb13.tgz
NetBSD 8.0powerpcpoedit-2.3nb10.tgz
NetBSD 8.0powerpcpoedit-2.3nb10.tgz
NetBSD 8.0powerpcpoedit-2.3nb12.tgz
NetBSD 8.0powerpcpoedit-2.3nb12.tgz
NetBSD 8.0x86_64poedit-2.3nb8.tgz
NetBSD 8.0x86_64poedit-2.3nb10.tgz
NetBSD 8.0x86_64poedit-2.3nb13.tgz
NetBSD 9.0aarch64poedit-2.3nb13.tgz
NetBSD 9.0aarch64poedit-2.3nb10.tgz
NetBSD 9.0aarch64poedit-2.3nb12.tgz
NetBSD 9.0alphapoedit-2.3nb12.tgz
NetBSD 9.0alphapoedit-2.3nb10.tgz
NetBSD 9.0earmv6hfpoedit-2.3nb10.tgz
NetBSD 9.0earmv6hfpoedit-2.3nb12.tgz
NetBSD 9.0earmv6hfpoedit-2.3nb13.tgz
NetBSD 9.0earmv7hfpoedit-2.3nb10.tgz
NetBSD 9.0earmv7hfpoedit-2.3nb10.tgz
NetBSD 9.0earmv7hfpoedit-2.3nb12.tgz
NetBSD 9.0earmv7hfpoedit-2.3nb13.tgz
NetBSD 9.0i386poedit-2.3nb12.tgz
NetBSD 9.0i386poedit-2.3nb10.tgz
NetBSD 9.0i386poedit-2.3nb13.tgz
NetBSD 9.0mips64ebpoedit-2.3nb10.tgz
NetBSD 9.0powerpcpoedit-2.3nb12.tgz
NetBSD 9.0powerpcpoedit-2.3nb10.tgz
NetBSD 9.0powerpcpoedit-2.3nb10.tgz
NetBSD 9.0powerpcpoedit-2.3nb10.tgz
NetBSD 9.0powerpcpoedit-2.3nb10.tgz
NetBSD 9.0powerpcpoedit-2.3nb12.tgz
NetBSD 9.0x86_64poedit-2.3nb13.tgz
NetBSD 9.0x86_64poedit-2.3nb14.tgz
NetBSD 9.0x86_64poedit-2.3nb13.tgz
NetBSD 9.0x86_64poedit-2.3nb10.tgz
NetBSD 9.0x86_64poedit-2.3nb12.tgz
NetBSD 9.0x86_64poedit-2.3nb12.tgz
NetBSD 9.0x86_64poedit-2.3nb14.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.