editors/nvi - The NetBSD Packages Collection

Berkeley nvi with additional features

Nvi is an implementation of the ex/vi text editor originally distributed
as part of the Fourth Berkeley Software Distribution (4BSD), by the
University of California, Berkeley. The source code to nvi is freely
available, and nvi may be freely redistributed.

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/automake devel/autoconf

Runtime dependencies

databases/db4

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 8.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 8.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 8.0i386nvi-1.81.6nb13.tgz
NetBSD 8.0i386nvi-1.81.6nb13.tgz
NetBSD 8.0powerpcnvi-1.81.6nb13.tgz
NetBSD 8.0powerpcnvi-1.81.6nb13.tgz
NetBSD 8.0powerpcnvi-1.81.6nb13.tgz
NetBSD 8.0powerpcnvi-1.81.6nb13.tgz
NetBSD 8.0x86_64nvi-1.81.6nb13.tgz
NetBSD 8.0x86_64nvi-1.81.6nb13.tgz
NetBSD 9.0aarch64nvi-1.81.6nb13.tgz
NetBSD 9.0aarch64nvi-1.81.6nb13.tgz
NetBSD 9.0aarch64nvi-1.81.6nb13.tgz
NetBSD 9.0alphanvi-1.81.6nb13.tgz
NetBSD 9.0alphanvi-1.81.6nb13.tgz
NetBSD 9.0alphanvi-1.81.6nb13.tgz
NetBSD 9.0earmnvi-1.81.6nb13.tgz
NetBSD 9.0earmnvi-1.81.6nb13.tgz
NetBSD 9.0earmnvi-1.81.6nb13.tgz
NetBSD 9.0earmv6hfnvi-1.81.6nb13.tgz
NetBSD 9.0earmv6hfnvi-1.81.6nb13.tgz
NetBSD 9.0earmv6hfnvi-1.81.6nb13.tgz
NetBSD 9.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 9.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 9.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 9.0earmv7hfnvi-1.81.6nb13.tgz
NetBSD 9.0i386nvi-1.81.6nb13.tgz
NetBSD 9.0i386nvi-1.81.6nb13.tgz
NetBSD 9.0mips64ebnvi-1.81.6nb13.tgz
NetBSD 9.0mips64ebnvi-1.81.6nb13.tgz
NetBSD 9.0mips64ebnvi-1.81.6nb13.tgz
NetBSD 9.0mips64ebnvi-1.81.6nb13.tgz
NetBSD 9.0mips64ebnvi-1.81.6nb13.tgz
NetBSD 9.0mipselnvi-1.81.6nb13.tgz
NetBSD 9.0mipselnvi-1.81.6nb13.tgz
NetBSD 9.0mipselnvi-1.81.6nb13.tgz
NetBSD 9.0mipselnvi-1.81.6nb13.tgz
NetBSD 9.0powerpcnvi-1.81.6nb13.tgz
NetBSD 9.0powerpcnvi-1.81.6nb13.tgz
NetBSD 9.0powerpcnvi-1.81.6nb13.tgz
NetBSD 9.0powerpcnvi-1.81.6nb13.tgz
NetBSD 9.0sparc64nvi-1.81.6nb13.tgz
NetBSD 9.0sparc64nvi-1.81.6nb13.tgz
NetBSD 9.0sparc64nvi-1.81.6nb13.tgz
NetBSD 9.0x86_64nvi-1.81.6nb13.tgz
NetBSD 9.0x86_64nvi-1.81.6nb13.tgz
NetBSD 9.0x86_64nvi-1.81.6nb13.tgz
NetBSD 9.0x86_64nvi-1.81.6nb13.tgz
NetBSD 9.0x86_64nvi-1.81.6nb13.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

wide-curses
Enable wide curses support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.