editors/fe - The NetBSD Packages Collection

Folding editor

Fe is a small and easy to use folding editor.

Fe allows to fold arbitrary text regions; it is not bound to syntactic
units.  Unlike Origami, folds are not attributed with a trailing
comment, instead you can put folds before or after any text in the
line, as you like.

Fe has no configuration or extension language and requires no setup.
Its user interface is emacs-like and it has menues for the very most
important functions to help beginners.  Further there is a reference
card.  It offers:

    * Regions and Emacs-like kill ring
    * Incremental search
    * Keyboard macros
    * Editing binary files
    * Multiple windows and views
    * Compose function for Latin 1 characters

In case you can't stand the emacs interface and want ultimate
flexibility, fe can easily be modified, because it is structured as an
editor library with a user interface frontend, all written in C.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffe-1.9.tgz
NetBSD 8.0earmv7hffe-1.9.tgz
NetBSD 8.0earmv7hffe-1.9.tgz
NetBSD 8.0i386fe-1.9.tgz
NetBSD 8.0i386fe-1.9.tgz
NetBSD 8.0powerpcfe-1.9.tgz
NetBSD 8.0powerpcfe-1.9.tgz
NetBSD 8.0powerpcfe-1.9.tgz
NetBSD 8.0powerpcfe-1.9.tgz
NetBSD 8.0x86_64fe-1.9.tgz
NetBSD 8.0x86_64fe-1.9.tgz
NetBSD 9.0aarch64fe-1.9.tgz
NetBSD 9.0aarch64fe-1.9.tgz
NetBSD 9.0aarch64fe-1.9.tgz
NetBSD 9.0alphafe-1.9.tgz
NetBSD 9.0alphafe-1.9.tgz
NetBSD 9.0alphafe-1.9.tgz
NetBSD 9.0earmfe-1.9.tgz
NetBSD 9.0earmfe-1.9.tgz
NetBSD 9.0earmfe-1.9.tgz
NetBSD 9.0earmv6hffe-1.9.tgz
NetBSD 9.0earmv6hffe-1.9.tgz
NetBSD 9.0earmv6hffe-1.9.tgz
NetBSD 9.0earmv7hffe-1.9.tgz
NetBSD 9.0earmv7hffe-1.9.tgz
NetBSD 9.0earmv7hffe-1.9.tgz
NetBSD 9.0earmv7hffe-1.9.tgz
NetBSD 9.0i386fe-1.9.tgz
NetBSD 9.0i386fe-1.9.tgz
NetBSD 9.0i386fe-1.9.tgz
NetBSD 9.0mips64ebfe-1.9.tgz
NetBSD 9.0mips64ebfe-1.9.tgz
NetBSD 9.0mips64ebfe-1.9.tgz
NetBSD 9.0mips64ebfe-1.9.tgz
NetBSD 9.0mips64ebfe-1.9.tgz
NetBSD 9.0powerpcfe-1.9.tgz
NetBSD 9.0powerpcfe-1.9.tgz
NetBSD 9.0powerpcfe-1.9.tgz
NetBSD 9.0powerpcfe-1.9.tgz
NetBSD 9.0sparc64fe-1.9.tgz
NetBSD 9.0sparc64fe-1.9.tgz
NetBSD 9.0sparc64fe-1.9.tgz
NetBSD 9.0sparcfe-1.9.tgz
NetBSD 9.0sparcfe-1.9.tgz
NetBSD 9.0sparcfe-1.9.tgz
NetBSD 9.0sparcfe-1.9.tgz
NetBSD 9.0sparcfe-1.9.tgz
NetBSD 9.0x86_64fe-1.9.tgz
NetBSD 9.0x86_64fe-1.9.tgz
NetBSD 9.0x86_64fe-1.9.tgz
NetBSD 9.0x86_64fe-1.9.tgz
NetBSD 9.0x86_64fe-1.9.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.