devel/py-confuse - The NetBSD Packages Collection

Painless YAML configuration

Confuse is a configuration library for Python that uses YAML. It takes
care of defaults, overrides, type checking, command-line integration,
human-readable errors, and standard OS-specific locations.

Here's what Confuse brings to the table:

-  An utterly sensible API resembling dictionary-and-list structures
   but providing transparent validation without lots of boilerplate
   code.
-  Combine configuration data from multiple sources. Using
   layering, Confuse allows user-specific configuration to seamlessly
   override system-wide configuration, which in turn overrides built-in
   defaults.
-  Look for configuration files in platform-specific paths.
-  Integration with command-line arguments via argparse or optparse
   from the standard library.

Build dependencies

pkgtools/cwrappers devel/py-setuptools

Runtime dependencies

textproc/py-yaml lang/python39 lang/python39

Binary packages

OSArchitectureVersion
NetBSD 9.0aarch64py27-confuse-1.6.0.tgz
NetBSD 9.0aarch64py310-confuse-1.6.0.tgz
NetBSD 9.0aarch64py36-confuse-1.6.0.tgz
NetBSD 9.0aarch64py37-confuse-1.6.0.tgz
NetBSD 9.0aarch64py38-confuse-1.6.0.tgz
NetBSD 9.0aarch64py39-confuse-1.6.0.tgz
NetBSD 9.0earmv6hfpy27-confuse-1.6.0.tgz
NetBSD 9.0earmv6hfpy310-confuse-1.6.0.tgz
NetBSD 9.0earmv6hfpy36-confuse-1.6.0.tgz
NetBSD 9.0earmv6hfpy37-confuse-1.6.0.tgz
NetBSD 9.0earmv6hfpy38-confuse-1.6.0.tgz
NetBSD 9.0earmv6hfpy39-confuse-1.6.0.tgz
NetBSD 9.0earmv7hfpy27-confuse-1.6.0.tgz
NetBSD 9.0earmv7hfpy310-confuse-1.6.0.tgz
NetBSD 9.0earmv7hfpy36-confuse-1.6.0.tgz
NetBSD 9.0earmv7hfpy37-confuse-1.6.0.tgz
NetBSD 9.0earmv7hfpy38-confuse-1.6.0.tgz
NetBSD 9.0earmv7hfpy39-confuse-1.6.0.tgz
NetBSD 9.0sparc64py39-confuse-1.6.0.tgz
NetBSD 9.0x86_64py27-confuse-1.6.0.tgz
NetBSD 9.0x86_64py310-confuse-1.6.0.tgz
NetBSD 9.0x86_64py36-confuse-1.6.0.tgz
NetBSD 9.0x86_64py37-confuse-1.6.0.tgz
NetBSD 9.0x86_64py38-confuse-1.6.0.tgz
NetBSD 9.0x86_64py39-confuse-1.6.0.tgz
NetBSD 9.0x86_64py27-confuse-1.6.0.tgz
NetBSD 9.0x86_64py310-confuse-1.6.0.tgz
NetBSD 9.0x86_64py37-confuse-1.6.0.tgz
NetBSD 9.0x86_64py38-confuse-1.6.0.tgz
NetBSD 9.0x86_64py39-confuse-1.6.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.