devel/p5-Moose - The NetBSD Packages Collection

Postmodern object system for Perl 5

Moose is an extension of the Perl 5 object system. The main goal of
Moose is to make Perl 5 Object Oriented programming easier, more
consistent and less tedious. With Moose you can think more about what
you want to do and less about the mechanics of OOP.

Additionally, Moose is built on top of Class::MOP, which is a metaclass
system for Perl 5. This means that Moose not only makes building normal
Perl 5 objects better, but it provides the power of metaclass
programming as well.

Build dependencies

devel/p5-Test-Fatal devel/p5-Test-Requires databases/p5-DBM-Deep time/p5-DateTime-Calendar-Mayan time/p5-DateTime-Format-MySQL devel/p5-Declare-Constraints-Simple devel/p5-IO-String misc/p5-Locale-US devel/p5-Module-Refresh devel/p5-Params-Coerce textproc/p5-Regexp-Common devel/p5-Test-Deep devel/p5-Test-Warnings devel/p5-Algorithm-C3 devel/p5-Test-CleanNamespaces www/p5-HTTP-Message devel/p5-PadWalker devel/p5-SUPER devel/p5-Test-Inline devel/p5-Test-LeakTrace devel/p5-Test-Memory-Cycle devel/p5-Test-Output devel/p5-Test-CheckDeps devel/p5-CPAN-Meta-Check www/p5-URI pkgtools/cwrappers

Runtime dependencies

devel/p5-Class-Load devel/p5-Class-Load-XS devel/p5-Data-OptList devel/p5-Devel-GlobalDestruction devel/p5-Devel-OverloadInfo devel/p5-Devel-StackTrace devel/p5-Dist-CheckConflicts devel/p5-Eval-Closure devel/p5-Module-Runtime devel/p5-Module-Runtime-Conflicts devel/p5-MRO-Compat devel/p5-Package-DeprecationManager devel/p5-Package-Stash devel/p5-Package-Stash-XS devel/p5-Params-Util devel/p5-Sub-Exporter devel/p5-Sub-Identify devel/p5-Task-Weaken devel/p5-Try-Tiny devel/p5-namespace-autoclean devel/p5-Scalar-List-Utils lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-Moose-2.2015nb1.tgz
NetBSD 8.0i386p5-Moose-2.2201.tgz
NetBSD 8.0i386p5-Moose-2.2201.tgz
NetBSD 8.0powerpcp5-Moose-2.2015nb1.tgz
NetBSD 8.0powerpcp5-Moose-2.2015nb1.tgz
NetBSD 8.0x86_64p5-Moose-2.2201.tgz
NetBSD 8.0x86_64p5-Moose-2.2201.tgz
NetBSD 9.0aarch64p5-Moose-2.2201.tgz
NetBSD 9.0aarch64p5-Moose-2.2201.tgz
NetBSD 9.0alphap5-Moose-2.2015nb1.tgz
NetBSD 9.0alphap5-Moose-2.2201.tgz
NetBSD 9.0alphap5-Moose-2.2201.tgz
NetBSD 9.0earmp5-Moose-2.2015nb1.tgz
NetBSD 9.0earmp5-Moose-2.2201.tgz
NetBSD 9.0earmp5-Moose-2.2201.tgz
NetBSD 9.0earmv4p5-Moose-2.2201.tgz
NetBSD 9.0earmv4p5-Moose-2.2201.tgz
NetBSD 9.0earmv6hfp5-Moose-2.2201.tgz
NetBSD 9.0earmv6hfp5-Moose-2.2201.tgz
NetBSD 9.0earmv7hfp5-Moose-2.2201.tgz
NetBSD 9.0earmv7hfp5-Moose-2.2201.tgz
NetBSD 9.0i386p5-Moose-2.2201.tgz
NetBSD 9.0i386p5-Moose-2.2201.tgz
NetBSD 9.0i386p5-Moose-2.2201.tgz
NetBSD 9.0m68kp5-Moose-2.2015nb1.tgz
NetBSD 9.0m68kp5-Moose-2.2201.tgz
NetBSD 9.0m68kp5-Moose-2.2201.tgz
NetBSD 9.0mips64ebp5-Moose-2.2015nb1.tgz
NetBSD 9.0mips64ebp5-Moose-2.2201.tgz
NetBSD 9.0mipselp5-Moose-2.2015nb1.tgz
NetBSD 9.0mipselp5-Moose-2.2015nb1.tgz
NetBSD 9.0mipselp5-Moose-2.2201.tgz
NetBSD 9.0mipselp5-Moose-2.2201.tgz
NetBSD 9.0powerpcp5-Moose-2.2015nb1.tgz
NetBSD 9.0powerpcp5-Moose-2.2015nb1.tgz
NetBSD 9.0sh3elp5-Moose-2.2015nb1.tgz
NetBSD 9.0sh3elp5-Moose-2.2201.tgz
NetBSD 9.0sh3elp5-Moose-2.2201.tgz
NetBSD 9.0sparc64p5-Moose-2.2015nb1.tgz
NetBSD 9.0sparc64p5-Moose-2.2201.tgz
NetBSD 9.0sparc64p5-Moose-2.2201.tgz
NetBSD 9.0sparcp5-Moose-2.2015nb1.tgz
NetBSD 9.0sparcp5-Moose-2.2015nb1.tgz
NetBSD 9.0sparcp5-Moose-2.2201.tgz
NetBSD 9.0sparcp5-Moose-2.2201.tgz
NetBSD 9.0x86_64p5-Moose-2.2201.tgz
NetBSD 9.0x86_64p5-Moose-2.2201.tgz
NetBSD 9.0x86_64p5-Moose-2.2201.tgz
NetBSD 9.0x86_64p5-Moose-2.2201.tgz
NetBSD 9.0x86_64p5-Moose-2.2201.tgz
NetBSD 9.0x86_64p5-Moose-2.2201nb1.tgz
NetBSD 9.99.96aarch64ebp5-Moose-2.2201.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.