devel/lua-cov - The NetBSD Packages Collection

Simple coverage analyzer for Lua scripts

LuaCov is a simple coverage analyzer for Lua scripts. When a Lua script is
run with the luacov module loaded, it generates a stats file with the number
of executions of each line of the script and its loaded modules. The luacov
command-line script then processes this file generating a report file which
allows one to visualize which code paths were not traversed, which is useful
for verifying the effectiveness of a test suite.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/lua53

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 8.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 8.0i386lua51-cov-0.14.0.tgz
NetBSD 8.0i386lua52-cov-0.14.0.tgz
NetBSD 8.0i386lua53-cov-0.14.0.tgz
NetBSD 8.0i386lua54-cov-0.14.0.tgz
NetBSD 8.0i386lua51-cov-0.14.0.tgz
NetBSD 8.0i386lua52-cov-0.14.0.tgz
NetBSD 8.0i386lua53-cov-0.14.0.tgz
NetBSD 8.0i386lua54-cov-0.14.0.tgz
NetBSD 8.0powerpclua51-cov-0.14.0.tgz
NetBSD 8.0powerpclua52-cov-0.14.0.tgz
NetBSD 8.0powerpclua53-cov-0.14.0.tgz
NetBSD 8.0powerpclua54-cov-0.14.0.tgz
NetBSD 8.0powerpclua51-cov-0.14.0.tgz
NetBSD 8.0powerpclua52-cov-0.14.0.tgz
NetBSD 8.0powerpclua53-cov-0.14.0.tgz
NetBSD 8.0powerpclua54-cov-0.14.0.tgz
NetBSD 8.0powerpclua51-cov-0.14.0.tgz
NetBSD 8.0powerpclua52-cov-0.14.0.tgz
NetBSD 8.0powerpclua53-cov-0.14.0.tgz
NetBSD 8.0powerpclua54-cov-0.14.0.tgz
NetBSD 8.0powerpclua51-cov-0.14.0.tgz
NetBSD 8.0powerpclua52-cov-0.14.0.tgz
NetBSD 8.0powerpclua53-cov-0.14.0.tgz
NetBSD 8.0powerpclua54-cov-0.14.0.tgz
NetBSD 8.0x86_64lua51-cov-0.14.0.tgz
NetBSD 8.0x86_64lua52-cov-0.14.0.tgz
NetBSD 8.0x86_64lua53-cov-0.14.0.tgz
NetBSD 8.0x86_64lua54-cov-0.14.0.tgz
NetBSD 8.0x86_64lua51-cov-0.14.0.tgz
NetBSD 8.0x86_64lua52-cov-0.14.0.tgz
NetBSD 8.0x86_64lua53-cov-0.14.0.tgz
NetBSD 8.0x86_64lua54-cov-0.14.0.tgz
NetBSD 9.0aarch64lua51-cov-0.14.0.tgz
NetBSD 9.0aarch64lua52-cov-0.14.0.tgz
NetBSD 9.0aarch64lua53-cov-0.14.0.tgz
NetBSD 9.0aarch64lua54-cov-0.14.0.tgz
NetBSD 9.0aarch64lua51-cov-0.14.0.tgz
NetBSD 9.0aarch64lua52-cov-0.14.0.tgz
NetBSD 9.0aarch64lua53-cov-0.14.0.tgz
NetBSD 9.0aarch64lua54-cov-0.14.0.tgz
NetBSD 9.0aarch64lua51-cov-0.14.0.tgz
NetBSD 9.0aarch64lua52-cov-0.14.0.tgz
NetBSD 9.0aarch64lua53-cov-0.14.0.tgz
NetBSD 9.0aarch64lua54-cov-0.14.0.tgz
NetBSD 9.0alphalua51-cov-0.14.0.tgz
NetBSD 9.0alphalua52-cov-0.14.0.tgz
NetBSD 9.0alphalua53-cov-0.14.0.tgz
NetBSD 9.0alphalua54-cov-0.14.0.tgz
NetBSD 9.0alphalua51-cov-0.14.0.tgz
NetBSD 9.0alphalua52-cov-0.14.0.tgz
NetBSD 9.0alphalua53-cov-0.14.0.tgz
NetBSD 9.0alphalua54-cov-0.14.0.tgz
NetBSD 9.0alphalua51-cov-0.14.0.tgz
NetBSD 9.0alphalua52-cov-0.14.0.tgz
NetBSD 9.0alphalua53-cov-0.14.0.tgz
NetBSD 9.0alphalua54-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua54-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua54-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv6hflua54-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua51-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua52-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua53-cov-0.14.0.tgz
NetBSD 9.0earmv7hflua54-cov-0.14.0.tgz
NetBSD 9.0i386lua51-cov-0.14.0.tgz
NetBSD 9.0i386lua52-cov-0.14.0.tgz
NetBSD 9.0i386lua53-cov-0.14.0.tgz
NetBSD 9.0i386lua54-cov-0.14.0.tgz
NetBSD 9.0i386lua51-cov-0.14.0.tgz
NetBSD 9.0i386lua52-cov-0.14.0.tgz
NetBSD 9.0i386lua53-cov-0.14.0.tgz
NetBSD 9.0i386lua54-cov-0.14.0.tgz
NetBSD 9.0i386lua51-cov-0.14.0.tgz
NetBSD 9.0i386lua52-cov-0.14.0.tgz
NetBSD 9.0i386lua53-cov-0.14.0.tgz
NetBSD 9.0i386lua54-cov-0.14.0.tgz
NetBSD 9.0mips64eblua51-cov-0.14.0.tgz
NetBSD 9.0mips64eblua52-cov-0.14.0.tgz
NetBSD 9.0mips64eblua53-cov-0.14.0.tgz
NetBSD 9.0mips64eblua54-cov-0.14.0.tgz
NetBSD 9.0mips64eblua51-cov-0.14.0.tgz
NetBSD 9.0mips64eblua52-cov-0.14.0.tgz
NetBSD 9.0mips64eblua53-cov-0.14.0.tgz
NetBSD 9.0mips64eblua54-cov-0.14.0.tgz
NetBSD 9.0mips64eblua51-cov-0.14.0.tgz
NetBSD 9.0mips64eblua52-cov-0.14.0.tgz
NetBSD 9.0mips64eblua53-cov-0.14.0.tgz
NetBSD 9.0mips64eblua54-cov-0.14.0.tgz
NetBSD 9.0mips64eblua51-cov-0.14.0.tgz
NetBSD 9.0mips64eblua52-cov-0.14.0.tgz
NetBSD 9.0mips64eblua53-cov-0.14.0.tgz
NetBSD 9.0mips64eblua54-cov-0.14.0.tgz
NetBSD 9.0mips64eblua51-cov-0.14.0.tgz
NetBSD 9.0mips64eblua52-cov-0.14.0.tgz
NetBSD 9.0mips64eblua53-cov-0.14.0.tgz
NetBSD 9.0mips64eblua54-cov-0.14.0.tgz
NetBSD 9.0powerpclua51-cov-0.14.0.tgz
NetBSD 9.0powerpclua52-cov-0.14.0.tgz
NetBSD 9.0powerpclua53-cov-0.14.0.tgz
NetBSD 9.0powerpclua54-cov-0.14.0.tgz
NetBSD 9.0powerpclua51-cov-0.14.0.tgz
NetBSD 9.0powerpclua52-cov-0.14.0.tgz
NetBSD 9.0powerpclua53-cov-0.14.0.tgz
NetBSD 9.0powerpclua54-cov-0.14.0.tgz
NetBSD 9.0powerpclua51-cov-0.14.0.tgz
NetBSD 9.0powerpclua52-cov-0.14.0.tgz
NetBSD 9.0powerpclua53-cov-0.14.0.tgz
NetBSD 9.0powerpclua54-cov-0.14.0.tgz
NetBSD 9.0powerpclua51-cov-0.14.0.tgz
NetBSD 9.0powerpclua52-cov-0.14.0.tgz
NetBSD 9.0powerpclua53-cov-0.14.0.tgz
NetBSD 9.0powerpclua54-cov-0.14.0.tgz
NetBSD 9.0sparc64lua51-cov-0.14.0.tgz
NetBSD 9.0sparc64lua52-cov-0.14.0.tgz
NetBSD 9.0sparc64lua53-cov-0.14.0.tgz
NetBSD 9.0sparc64lua54-cov-0.14.0.tgz
NetBSD 9.0sparc64lua51-cov-0.14.0.tgz
NetBSD 9.0sparc64lua52-cov-0.14.0.tgz
NetBSD 9.0sparc64lua53-cov-0.14.0.tgz
NetBSD 9.0sparc64lua54-cov-0.14.0.tgz
NetBSD 9.0sparc64lua51-cov-0.14.0.tgz
NetBSD 9.0sparc64lua52-cov-0.14.0.tgz
NetBSD 9.0sparc64lua53-cov-0.14.0.tgz
NetBSD 9.0sparc64lua54-cov-0.14.0.tgz
NetBSD 9.0sparclua51-cov-0.14.0.tgz
NetBSD 9.0sparclua52-cov-0.14.0.tgz
NetBSD 9.0sparclua53-cov-0.14.0.tgz
NetBSD 9.0sparclua54-cov-0.14.0.tgz
NetBSD 9.0sparclua51-cov-0.14.0.tgz
NetBSD 9.0sparclua52-cov-0.14.0.tgz
NetBSD 9.0sparclua53-cov-0.14.0.tgz
NetBSD 9.0sparclua54-cov-0.14.0.tgz
NetBSD 9.0sparclua51-cov-0.14.0.tgz
NetBSD 9.0sparclua52-cov-0.14.0.tgz
NetBSD 9.0sparclua53-cov-0.14.0.tgz
NetBSD 9.0sparclua54-cov-0.14.0.tgz
NetBSD 9.0sparclua51-cov-0.14.0.tgz
NetBSD 9.0sparclua52-cov-0.14.0.tgz
NetBSD 9.0sparclua53-cov-0.14.0.tgz
NetBSD 9.0sparclua54-cov-0.14.0.tgz
NetBSD 9.0sparclua51-cov-0.14.0.tgz
NetBSD 9.0sparclua52-cov-0.14.0.tgz
NetBSD 9.0sparclua53-cov-0.14.0.tgz
NetBSD 9.0sparclua54-cov-0.14.0.tgz
NetBSD 9.0x86_64lua51-cov-0.14.0.tgz
NetBSD 9.0x86_64lua52-cov-0.14.0.tgz
NetBSD 9.0x86_64lua53-cov-0.14.0.tgz
NetBSD 9.0x86_64lua54-cov-0.14.0.tgz
NetBSD 9.0x86_64lua51-cov-0.14.0.tgz
NetBSD 9.0x86_64lua52-cov-0.14.0.tgz
NetBSD 9.0x86_64lua53-cov-0.14.0.tgz
NetBSD 9.0x86_64lua54-cov-0.14.0.tgz
NetBSD 9.0x86_64lua51-cov-0.14.0.tgz
NetBSD 9.0x86_64lua52-cov-0.14.0.tgz
NetBSD 9.0x86_64lua53-cov-0.14.0.tgz
NetBSD 9.0x86_64lua54-cov-0.14.0.tgz
NetBSD 9.0x86_64lua51-cov-0.14.0.tgz
NetBSD 9.0x86_64lua52-cov-0.14.0.tgz
NetBSD 9.0x86_64lua53-cov-0.14.0.tgz
NetBSD 9.0x86_64lua54-cov-0.14.0.tgz
NetBSD 9.0x86_64lua51-cov-0.14.0.tgz
NetBSD 9.0x86_64lua52-cov-0.14.0.tgz
NetBSD 9.0x86_64lua53-cov-0.14.0.tgz
NetBSD 9.0x86_64lua54-cov-0.14.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.