devel/hs-indexed-traversable-instances - The NetBSD Packages Collection

More instances of type classes from indexed-traversable

This package provides extra instances for type-classes in the
indexed-traversable package.

The intention is to keep this package minimal; it provides instances that
formely existed in lens or optics-extra. We recommend putting other
instances directly into their defining packages. The indexed-traversable
package is light, having only GHC boot libraries as its dependencies.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/hs-indexed-traversable devel/hs-OneTuple devel/hs-tagged devel/hs-unordered-containers devel/hs-vector lang/ghc94 devel/hs-indexed-traversable devel/hs-OneTuple devel/hs-tagged devel/hs-unordered-containers devel/hs-vector

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 10.0x86_64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 10.0x86_64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 8.0x86_64hs-indexed-traversable-instances-0.1.1nb2.tgz
NetBSD 8.0x86_64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 9.0aarch64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 9.0aarch64hs-indexed-traversable-instances-0.1.1nb2.tgz
NetBSD 9.0aarch64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 9.0x86_64hs-indexed-traversable-instances-0.1.1nb2.tgz
NetBSD 9.0x86_64hs-indexed-traversable-instances-0.1.1nb2.tgz
NetBSD 9.0x86_64hs-indexed-traversable-instances-0.1.1nb2.tgz
NetBSD 9.0x86_64hs-indexed-traversable-instances-0.1.1.1nb1.tgz
NetBSD 9.0x86_64hs-indexed-traversable-instances-0.1.1nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.