devel/haskell-language-server - The NetBSD Packages Collection

LSP server for GHC

The haskell-language-server (HLS) project is an implementation of a server
(a "language server") for the Language Server Protocol (LSP). A language
server talks to a client (typically an editor), which can ask the server to
perform various operations, such as reporting errors or providing code
completions. The advantage of this system is that clients and servers can
interoperate more easily so long as they all speak the LSP protocol. In the
case of HLS, that means that it can be used with many different editors,
since editor support for the LSP protocol is now widespread.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/hs-optparse-applicative converters/hs-aeson-pretty converters/hs-aeson devel/hs-hashable devel/hs-unordered-containers devel/hs-async converters/hs-base16-bytestring security/hs-cryptohash-sha1 devel/hs-data-default misc/hs-extra devel/hs-ghcide devel/hs-ghc-paths devel/hs-safe-exceptions devel/hs-hie-bios devel/hs-unliftio-core textproc/hs-prettyprinter sysutils/hs-temporary devel/hs-hiedb databases/hs-sqlite-simple devel/hs-hls-graph devel/hs-hls-plugin-api devel/hs-lens devel/hs-lsp devel/hs-lsp-types textproc/hs-regex-tdfa sysutils/hs-hslogger devel/hs-githash devel/hs-optparse-simple devel/hs-hls-cabal-plugin devel/hs-hls-call-hierarchy-plugin devel/hs-hls-cabal-fmt-plugin devel/hs-hls-cabal-fmt-plugin devel/hs-hls-change-type-signature-plugin devel/hs-hls-class-plugin devel/hs-hls-explicit-imports-plugin devel/hs-hls-refine-imports-plugin devel/hs-hls-retrie-plugin devel/hs-hls-hlint-plugin devel/hs-hls-module-name-plugin devel/hs-hls-pragmas-plugin devel/hs-hls-splice-plugin devel/hs-hls-refactor-plugin devel/hs-hls-alternate-number-format-plugin devel/hs-hls-qualify-imported-names-plugin devel/hs-hls-code-range-plugin devel/hs-hls-gadt-plugin devel/hs-hls-explicit-fixity-plugin devel/hs-hls-explicit-fixity-plugin devel/hs-hls-explicit-record-fields-plugin devel/hs-hls-fourmolu-plugin devel/hs-gitrev lang/ghc94 devel/hs-optparse-applicative converters/hs-aeson-pretty converters/hs-aeson devel/hs-hashable devel/hs-unordered-containers devel/hs-async converters/hs-base16-bytestring security/hs-cryptohash-sha1 devel/hs-data-default devel/hs-ghcide devel/hs-ghc-paths devel/hs-safe-exceptions devel/hs-unliftio-core textproc/hs-prettyprinter sysutils/hs-temporary devel/hs-hiedb databases/hs-sqlite-simple devel/hs-hls-graph devel/hs-hls-plugin-api devel/hs-lens devel/hs-lsp devel/hs-lsp-types textproc/hs-regex-tdfa sysutils/hs-hslogger devel/hs-githash devel/hs-optparse-simple devel/hs-hls-cabal-plugin devel/hs-hls-call-hierarchy-plugin devel/hs-hls-change-type-signature-plugin devel/hs-hls-class-plugin devel/hs-hls-explicit-imports-plugin devel/hs-hls-refine-imports-plugin devel/hs-hls-retrie-plugin devel/hs-hls-hlint-plugin devel/hs-hls-module-name-plugin devel/hs-hls-pragmas-plugin devel/hs-hls-splice-plugin devel/hs-hls-refactor-plugin devel/hs-hls-alternate-number-format-plugin devel/hs-hls-qualify-imported-names-plugin devel/hs-hls-code-range-plugin devel/hs-hls-gadt-plugin devel/hs-hls-explicit-record-fields-plugin devel/hs-hls-fourmolu-plugin devel/hs-gitrev

Binary packages

OSArchitectureVersion
NetBSD 10.0x86_64haskell-language-server-1.6.1.1nb6.tgz
NetBSD 10.0x86_64haskell-language-server-1.6.1.1nb5.tgz
NetBSD 8.0x86_64haskell-language-server-1.6.1.1nb2.tgz
NetBSD 8.0x86_64haskell-language-server-1.6.1.1nb5.tgz
NetBSD 9.0x86_64haskell-language-server-1.6.1.1nb2.tgz
NetBSD 9.0x86_64haskell-language-server-1.6.1.1nb2.tgz
NetBSD 9.0x86_64haskell-language-server-1.6.1.1nb2.tgz
NetBSD 9.0x86_64haskell-language-server-1.6.1.1nb5.tgz
NetBSD 9.0x86_64haskell-language-server-1.6.1.1nb2.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.