devel/avl - The NetBSD Packages Collection

Library for manipulation of balanced binary trees

This is a library in ANSI C for manipulation of balanced binary
trees.  Functions for use with three varieties of AVL tree and
one type of red-black tree are included.  There is full documentation,
including an explanation of what AVL and red-black trees are and why
you'd use them, in Texinfo, Info, HTML, and plain text formats.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfavl-1.4.0.tgz
NetBSD 8.0earmv7hfavl-1.4.0.tgz
NetBSD 8.0earmv7hfavl-1.4.0.tgz
NetBSD 8.0i386avl-1.4.0.tgz
NetBSD 8.0i386avl-1.4.0.tgz
NetBSD 8.0powerpcavl-1.4.0.tgz
NetBSD 8.0powerpcavl-1.4.0.tgz
NetBSD 8.0powerpcavl-1.4.0.tgz
NetBSD 8.0powerpcavl-1.4.0.tgz
NetBSD 8.0x86_64avl-1.4.0.tgz
NetBSD 8.0x86_64avl-1.4.0.tgz
NetBSD 9.0aarch64avl-1.4.0.tgz
NetBSD 9.0aarch64avl-1.4.0.tgz
NetBSD 9.0aarch64avl-1.4.0.tgz
NetBSD 9.0alphaavl-1.4.0.tgz
NetBSD 9.0alphaavl-1.4.0.tgz
NetBSD 9.0alphaavl-1.4.0.tgz
NetBSD 9.0earmavl-1.4.0.tgz
NetBSD 9.0earmavl-1.4.0.tgz
NetBSD 9.0earmavl-1.4.0.tgz
NetBSD 9.0earmv6hfavl-1.4.0.tgz
NetBSD 9.0earmv6hfavl-1.4.0.tgz
NetBSD 9.0earmv6hfavl-1.4.0.tgz
NetBSD 9.0earmv7hfavl-1.4.0.tgz
NetBSD 9.0earmv7hfavl-1.4.0.tgz
NetBSD 9.0earmv7hfavl-1.4.0.tgz
NetBSD 9.0earmv7hfavl-1.4.0.tgz
NetBSD 9.0i386avl-1.4.0.tgz
NetBSD 9.0i386avl-1.4.0.tgz
NetBSD 9.0i386avl-1.4.0.tgz
NetBSD 9.0mips64ebavl-1.4.0.tgz
NetBSD 9.0mips64ebavl-1.4.0.tgz
NetBSD 9.0mips64ebavl-1.4.0.tgz
NetBSD 9.0mips64ebavl-1.4.0.tgz
NetBSD 9.0mips64ebavl-1.4.0.tgz
NetBSD 9.0powerpcavl-1.4.0.tgz
NetBSD 9.0powerpcavl-1.4.0.tgz
NetBSD 9.0powerpcavl-1.4.0.tgz
NetBSD 9.0powerpcavl-1.4.0.tgz
NetBSD 9.0sparc64avl-1.4.0.tgz
NetBSD 9.0sparc64avl-1.4.0.tgz
NetBSD 9.0sparc64avl-1.4.0.tgz
NetBSD 9.0sparcavl-1.4.0.tgz
NetBSD 9.0sparcavl-1.4.0.tgz
NetBSD 9.0sparcavl-1.4.0.tgz
NetBSD 9.0sparcavl-1.4.0.tgz
NetBSD 9.0sparcavl-1.4.0.tgz
NetBSD 9.0x86_64avl-1.4.0.tgz
NetBSD 9.0x86_64avl-1.4.0.tgz
NetBSD 9.0x86_64avl-1.4.0.tgz
NetBSD 9.0x86_64avl-1.4.0.tgz
NetBSD 9.0x86_64avl-1.4.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.