databases/ruby-dm-constraints - The NetBSD Packages Collection

DataMapper plugin constraining relationships

Plugin that adds foreign key constraints to associations.  Currently
supports only PostgreSQL and MySQL

All constraints are added to the underlying database, but constraining
is implemented in pure ruby.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

databases/ruby-dm-core lang/ruby32-base

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0aarch64ruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0aarch64ruby33-dm-constraints-1.2.0.tgz
NetBSD 10.0aarch64ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0aarch64ruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0aarch64ebruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv6hfruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv6hfruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv6hfruby33-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv6hfruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv6hfruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv7hfruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv7hfruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv7hfruby33-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv7hfruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0earmv7hfruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0i386ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0i386ruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0i386ruby33-dm-constraints-1.2.0.tgz
NetBSD 10.0i386ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0i386ruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby26-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby27-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby30-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby26-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby27-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby30-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0powerpcruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0sparc64ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0x86_64ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0x86_64ruby32-dm-constraints-1.2.0.tgz
NetBSD 10.0x86_64ruby33-dm-constraints-1.2.0.tgz
NetBSD 10.0x86_64ruby31-dm-constraints-1.2.0.tgz
NetBSD 10.0x86_64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0aarch64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0aarch64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0aarch64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0alpharuby26-dm-constraints-1.2.0.tgz
NetBSD 9.0alpharuby27-dm-constraints-1.2.0.tgz
NetBSD 9.0alpharuby30-dm-constraints-1.2.0.tgz
NetBSD 9.0alpharuby31-dm-constraints-1.2.0.tgz
NetBSD 9.0earmruby26-dm-constraints-1.2.0.tgz
NetBSD 9.0earmruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0earmruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0earmruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv6hfruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv6hfruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv6hfruby33-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv6hfruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv6hfruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv7hfruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv7hfruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv7hfruby33-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv7hfruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0earmv7hfruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0i386ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0i386ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0i386ruby33-dm-constraints-1.2.0.tgz
NetBSD 9.0i386ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0i386ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0m68kruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0mips64ebruby26-dm-constraints-1.2.0.tgz
NetBSD 9.0mips64ebruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0mips64ebruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0mips64ebruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby24-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby25-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby26-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby24-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby25-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby26-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby24-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby25-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby26-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0powerpcruby33-dm-constraints-1.2.0.tgz
NetBSD 9.0sparc64ruby26-dm-constraints-1.2.0.tgz
NetBSD 9.0sparc64ruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0sparc64ruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0sparc64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0sparc64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0sparcruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0sparcruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0sparcruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0vaxruby27-dm-constraints-1.2.0.tgz
NetBSD 9.0vaxruby30-dm-constraints-1.2.0.tgz
NetBSD 9.0vaxruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0vaxruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0x86_64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0x86_64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.0x86_64ruby33-dm-constraints-1.2.0.tgz
NetBSD 9.0x86_64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.0x86_64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.3x86_64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.3x86_64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.3x86_64ruby33-dm-constraints-1.2.0.tgz
NetBSD 9.3x86_64ruby31-dm-constraints-1.2.0.tgz
NetBSD 9.3x86_64ruby32-dm-constraints-1.2.0.tgz
NetBSD 9.3x86_64ruby33-dm-constraints-1.2.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.