databases/p5-DBIx-Class-UUIDColumns - The NetBSD Packages Collection

Implicit uuid columns for DBIx::Class

This DBIx::Class component resembles the behaviour of Class::DBI::UUID,
to make some columns implicitly created as uuid.

When loaded, UUIDColumns will search for a suitable uuid generation
module from the following list of supported modules:

    Data::UUID APR::UUID* UUID Win32::Guidgen Win32API::GUID

If no supporting module can be found, an exception will be thrown.

*APR::UUID will not be loaded under OpenBSD due to an as yet
unidentified XS issue.

Build dependencies

databases/p5-DBD-SQLite pkgtools/cwrappers

Runtime dependencies

databases/p5-DBIx-Class devel/p5-Data-UUID devel/p5-Class-Accessor-Grouped lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 8.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 8.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 8.0i386p5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 8.0i386p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 8.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 8.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0aarch64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0aarch64p5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0aarch64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0aarch64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0alphap5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0alphap5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0alphap5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0alphap5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0earmp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv6hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0earmv7hfp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0i386p5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0i386p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0i386p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0mips64ebp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0mipselp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0mipselp5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0mipselp5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0sparc64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0sparc64p5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0sparc64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0sparc64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb9.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz
NetBSD 9.0x86_64p5-DBIx-Class-UUIDColumns-0.02006nb10.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.