databases/p5-DBD-XBase - The NetBSD Packages Collection

Perl DBI/DBD driver for XBase (dBase/FoxPro) databases

XBase module provides access to XBase (dBase, Fox*) dbf files.  It also
handles memo files (dbt, fpt) and to certain extend index files (ndx, ntx,
mdx, idx and cdx).  The DBD::XBase is a database driver for DBI and provides
simple SQL interface to reading and writing the database files.  So this
package offers two ways of accessing your beloved data in dbf files: XBase.pm
and DBD::XBase.  It is recommend using DBD::XBase and only resort to XBase.pm
if you need something special which is not supported by the DBI interface.

Build dependencies

pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

databases/p5-DBI lang/perl5 lang/perl5 databases/p5-DBI

Binary packages

OSArchitectureVersion
NetBSD 10.0aarch64p5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0aarch64p5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0aarch64ebp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0alphap5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0alphap5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0earmv6hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0earmv6hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0earmv7hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0earmv7hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0i386p5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0i386p5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0m68kp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0powerpcp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0powerpcp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0sparc64p5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0sparcp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0vaxp5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0x86_64p5-DBD-XBase-1.08nb7.tgz
NetBSD 10.0x86_64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0aarch64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0aarch64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0alphap5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0alphap5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0earmp5-DBD-XBase-1.08nb6.tgz
NetBSD 9.0earmv6hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0earmv6hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0earmv7hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0earmv7hfp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0i386p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0i386p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0mips64ebp5-DBD-XBase-1.08nb6.tgz
NetBSD 9.0powerpcp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0powerpcp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0powerpcp5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0sparc64p5-DBD-XBase-1.08nb6.tgz
NetBSD 9.0sparc64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0x86_64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.0x86_64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.3x86_64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.3x86_64p5-DBD-XBase-1.08nb7.tgz
NetBSD 9.3x86_64p5-DBD-XBase-1.08nb7.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.