cross/mingw-w64-x86_64-crt - The NetBSD Packages Collection

Mingw-w64 C runtime for win64 cross-development

Mingw-w64 is an advancement of the original mingw.org project,
created to support the GCC compiler on Windows systems. It has
forked it in 2007 in order to provide support for 64 bits and new
APIs. It has since then gained widespread use and distribution.

This package provides C runtime for mingw-w64 x86_64 target.

Build dependencies

cross/mingw-w64-x86_64-gcc-bootstrap pkgtools/cwrappers devel/gmake lang/perl5

Runtime dependencies

cross/mingw-w64-x86_64-headers

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 8.0earmv7hfmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 8.0earmv7hfmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 8.0i386mingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 8.0i386mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 8.0powerpcmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 8.0powerpcmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 8.0x86_64mingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 8.0x86_64mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0aarch64mingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0aarch64mingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0aarch64mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0earmmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0earmmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0earmmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0earmv6hfmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0earmv6hfmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0earmv6hfmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0earmv7hfmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0earmv7hfmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0earmv7hfmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0earmv7hfmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0i386mingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0i386mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0mips64ebmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0mips64ebmingw-w64-x86_64-crt-7.0.0nb1.tgz
NetBSD 9.0mips64ebmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0mips64ebmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0mips64ebmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0mipselmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0mipselmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0mipselmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0powerpcmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0powerpcmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0powerpcmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0powerpcmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0sparc64mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0sparc64mingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0sparc64mingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0sparcmingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0sparcmingw-w64-x86_64-crt-7.0.0nb1.tgz
NetBSD 9.0sparcmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0sparcmingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0sparcmingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0x86_64mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0x86_64mingw-w64-x86_64-crt-9.0.0.tgz
NetBSD 9.0x86_64mingw-w64-x86_64-crt-8.0.0.tgz
NetBSD 9.0x86_64mingw-w64-x86_64-crt-8.0.0nb1.tgz
NetBSD 9.0x86_64mingw-w64-x86_64-crt-9.0.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.