cross/avr-libc - The NetBSD Packages Collection

C and math library for Atmel AVR 8-bit microcontrollers

This is avr-libc. It is a C library implementation for use
with GNU GCC and GNU binutils for development of programs for
Atmel's AVR microcontrollers.

This library implements a subset of common C library functions, some
Atmel AVR specific additions (like handling AVR's IO facilities,
EEPROM etc.), as well as a 32-bit floating point math library (-lm).

Everything is designed and implemented to cooperate with avr-gcc and
avr-binutils.

For details on installing and using AVR Libc, see the users manual in the
doc/api directory or online at:

  http://savannah.nongnu.org/projects/avr-libc/

Build dependencies

print/tex-alphalph devel/doxygen fonts/tex-psnfss fonts/tex-wasysym graphics/netpbm graphics/tex-epstopdf print/tex-adjustbox print/tex-caption print/tex-collectbox print/tex-colortbl fonts/tex-ec print/tex-epstopdf-pkg print/tex-etoc print/tex-fancyhdr print/tex-fancyvrb print/tex-float print/tex-geometry print/tex-graphics-cfg print/tex-hanging print/tex-hyperref print/tex-latex-bin print/tex-multirow print/tex-natbib print/tex-newunicodechar print/tex-pgf print/tex-sectsty print/tex-stackengine print/tex-tabu print/tex-tocloft print/tex-ulem print/tex-xcolor print/tex-xkeyval print/fig2dev textproc/makeindexk pkgtools/cwrappers devel/gmake lang/perl5

Runtime dependencies

cross/avr-binutils cross/avr-gcc

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfavr-libc-2.0.0nb6.tgz
NetBSD 8.0earmv7hfavr-libc-2.0.0nb4.tgz
NetBSD 8.0earmv7hfavr-libc-2.0.0nb5.tgz
NetBSD 8.0i386avr-libc-2.0.0nb4.tgz
NetBSD 8.0i386avr-libc-2.0.0nb5.tgz
NetBSD 8.0x86_64avr-libc-2.0.0nb4.tgz
NetBSD 8.0x86_64avr-libc-2.0.0nb5.tgz
NetBSD 9.0aarch64avr-libc-2.0.0nb6.tgz
NetBSD 9.0aarch64avr-libc-2.0.0nb4.tgz
NetBSD 9.0aarch64avr-libc-2.0.0nb5.tgz
NetBSD 9.0earmavr-libc-2.0.0nb6.tgz
NetBSD 9.0earmavr-libc-2.0.0nb5.tgz
NetBSD 9.0earmavr-libc-2.0.0nb6.tgz
NetBSD 9.0earmv6hfavr-libc-2.0.0nb6.tgz
NetBSD 9.0earmv6hfavr-libc-2.0.0nb4.tgz
NetBSD 9.0earmv6hfavr-libc-2.0.0nb5.tgz
NetBSD 9.0earmv7hfavr-libc-2.0.0nb6.tgz
NetBSD 9.0earmv7hfavr-libc-2.0.0nb4.tgz
NetBSD 9.0earmv7hfavr-libc-2.0.0nb5.tgz
NetBSD 9.0earmv7hfavr-libc-2.0.0nb6.tgz
NetBSD 9.0i386avr-libc-2.0.0nb4.tgz
NetBSD 9.0i386avr-libc-2.0.0nb5.tgz
NetBSD 9.0i386avr-libc-2.0.0nb6.tgz
NetBSD 9.0sparc64avr-libc-2.0.0nb6.tgz
NetBSD 9.0sparc64avr-libc-2.0.0nb4.tgz
NetBSD 9.0sparc64avr-libc-2.0.0nb5.tgz
NetBSD 9.0sparc64avr-libc-2.0.0nb6.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb5.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb6.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb6.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb4.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb5.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb6.tgz
NetBSD 9.0x86_64avr-libc-2.0.0nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

doc
Include the documentation.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.