converters/skf - The NetBSD Packages Collection

Simple Kanji Filter - i18n kanji converter

skf is an i18n-capable kanji filter.  It works like i18n enhanced
nkf-1.6.  More specifically, skf is intended to read documents in
various languages and codes using kanji or unicode capable display
devices.  skf provides basic kanji code conversion features, include
to/from JIS, EUC, Shift-JIS, Unicode, and Vendor specific codes.  skf
also includes decoder for various code appears in the Net.  Unlike
nkf, it does not provide broken jis recovery nor mime encoding, but it
has support for ISO-8859's, European domestic set, JIS X-0212/X-0213
code, has IBM/MS vendor specific code support and can add other code
support easily.

Build dependencies

pkgtools/cwrappers lang/perl5

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfskf-2.00.4nb5.tgz
NetBSD 8.0earmv7hfskf-2.00.4nb4.tgz
NetBSD 8.0earmv7hfskf-2.00.4nb5.tgz
NetBSD 8.0i386skf-2.00.4nb4.tgz
NetBSD 8.0i386skf-2.00.4nb5.tgz
NetBSD 8.0powerpcskf-2.00.4nb4.tgz
NetBSD 8.0powerpcskf-2.00.4nb5.tgz
NetBSD 8.0powerpcskf-2.00.4nb5.tgz
NetBSD 8.0powerpcskf-2.00.4nb5.tgz
NetBSD 8.0x86_64skf-2.00.4nb4.tgz
NetBSD 8.0x86_64skf-2.00.4nb5.tgz
NetBSD 9.0aarch64skf-2.00.4nb5.tgz
NetBSD 9.0aarch64skf-2.00.4nb4.tgz
NetBSD 9.0aarch64skf-2.00.4nb5.tgz
NetBSD 9.0alphaskf-2.00.4nb5.tgz
NetBSD 9.0alphaskf-2.00.4nb4.tgz
NetBSD 9.0alphaskf-2.00.4nb5.tgz
NetBSD 9.0earmskf-2.00.4nb4.tgz
NetBSD 9.0earmskf-2.00.4nb5.tgz
NetBSD 9.0earmskf-2.00.4nb5.tgz
NetBSD 9.0earmv6hfskf-2.00.4nb5.tgz
NetBSD 9.0earmv6hfskf-2.00.4nb4.tgz
NetBSD 9.0earmv6hfskf-2.00.4nb5.tgz
NetBSD 9.0earmv7hfskf-2.00.4nb5.tgz
NetBSD 9.0earmv7hfskf-2.00.4nb4.tgz
NetBSD 9.0earmv7hfskf-2.00.4nb5.tgz
NetBSD 9.0earmv7hfskf-2.00.4nb5.tgz
NetBSD 9.0i386skf-2.00.4nb4.tgz
NetBSD 9.0i386skf-2.00.4nb5.tgz
NetBSD 9.0mips64ebskf-2.00.4nb5.tgz
NetBSD 9.0mips64ebskf-2.00.4nb4.tgz
NetBSD 9.0mips64ebskf-2.00.4nb4.tgz
NetBSD 9.0mips64ebskf-2.00.4nb4.tgz
NetBSD 9.0mips64ebskf-2.00.4nb5.tgz
NetBSD 9.0powerpcskf-2.00.4nb5.tgz
NetBSD 9.0powerpcskf-2.00.4nb4.tgz
NetBSD 9.0powerpcskf-2.00.4nb5.tgz
NetBSD 9.0powerpcskf-2.00.4nb5.tgz
NetBSD 9.0sparc64skf-2.00.4nb5.tgz
NetBSD 9.0sparc64skf-2.00.4nb4.tgz
NetBSD 9.0sparc64skf-2.00.4nb5.tgz
NetBSD 9.0sparcskf-2.00.4nb5.tgz
NetBSD 9.0sparcskf-2.00.4nb4.tgz
NetBSD 9.0sparcskf-2.00.4nb4.tgz
NetBSD 9.0sparcskf-2.00.4nb4.tgz
NetBSD 9.0sparcskf-2.00.4nb5.tgz
NetBSD 9.0vaxskf-2.00.4nb4.tgz
NetBSD 9.0x86_64skf-2.00.4nb5.tgz
NetBSD 9.0x86_64skf-2.00.4nb5.tgz
NetBSD 9.0x86_64skf-2.00.4nb4.tgz
NetBSD 9.0x86_64skf-2.00.4nb5.tgz
NetBSD 9.0x86_64skf-2.00.4nb5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.