converters/rpm2cpio - The NetBSD Packages Collection

Convert .rpm files for extraction with cpio, needs just perl

Convert .rpm files for extraction with /usr/bin/cpio

Quoting the author:

why does the world need another rpm2cpio?  because the existing one
won't build unless you have half a ton of things that aren't really
required for it, since it uses the same library used to extract RPM's.
in particular, it won't build on the HPsUX box i'm on.

(this one needs just perl)

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfrpm2cpio-1.3nb6.tgz
NetBSD 8.0earmv7hfrpm2cpio-1.3nb5.tgz
NetBSD 8.0earmv7hfrpm2cpio-1.3nb6.tgz
NetBSD 8.0i386rpm2cpio-1.3nb5.tgz
NetBSD 8.0i386rpm2cpio-1.3nb6.tgz
NetBSD 8.0powerpcrpm2cpio-1.3nb5.tgz
NetBSD 8.0powerpcrpm2cpio-1.3nb6.tgz
NetBSD 8.0powerpcrpm2cpio-1.3nb6.tgz
NetBSD 8.0powerpcrpm2cpio-1.3nb6.tgz
NetBSD 8.0x86_64rpm2cpio-1.3nb5.tgz
NetBSD 8.0x86_64rpm2cpio-1.3nb6.tgz
NetBSD 9.0aarch64rpm2cpio-1.3nb6.tgz
NetBSD 9.0aarch64rpm2cpio-1.3nb5.tgz
NetBSD 9.0aarch64rpm2cpio-1.3nb6.tgz
NetBSD 9.0alpharpm2cpio-1.3nb6.tgz
NetBSD 9.0alpharpm2cpio-1.3nb5.tgz
NetBSD 9.0alpharpm2cpio-1.3nb6.tgz
NetBSD 9.0earmrpm2cpio-1.3nb5.tgz
NetBSD 9.0earmrpm2cpio-1.3nb6.tgz
NetBSD 9.0earmrpm2cpio-1.3nb6.tgz
NetBSD 9.0earmv6hfrpm2cpio-1.3nb6.tgz
NetBSD 9.0earmv6hfrpm2cpio-1.3nb5.tgz
NetBSD 9.0earmv6hfrpm2cpio-1.3nb6.tgz
NetBSD 9.0earmv7hfrpm2cpio-1.3nb6.tgz
NetBSD 9.0earmv7hfrpm2cpio-1.3nb5.tgz
NetBSD 9.0earmv7hfrpm2cpio-1.3nb6.tgz
NetBSD 9.0earmv7hfrpm2cpio-1.3nb6.tgz
NetBSD 9.0i386rpm2cpio-1.3nb5.tgz
NetBSD 9.0i386rpm2cpio-1.3nb6.tgz
NetBSD 9.0i386rpm2cpio-1.3nb6.tgz
NetBSD 9.0mips64ebrpm2cpio-1.3nb6.tgz
NetBSD 9.0mips64ebrpm2cpio-1.3nb5.tgz
NetBSD 9.0mips64ebrpm2cpio-1.3nb5.tgz
NetBSD 9.0mips64ebrpm2cpio-1.3nb5.tgz
NetBSD 9.0mips64ebrpm2cpio-1.3nb6.tgz
NetBSD 9.0mipselrpm2cpio-1.3nb6.tgz
NetBSD 9.0mipselrpm2cpio-1.3nb5.tgz
NetBSD 9.0mipselrpm2cpio-1.3nb5.tgz
NetBSD 9.0mipselrpm2cpio-1.3nb6.tgz
NetBSD 9.0powerpcrpm2cpio-1.3nb6.tgz
NetBSD 9.0powerpcrpm2cpio-1.3nb5.tgz
NetBSD 9.0powerpcrpm2cpio-1.3nb6.tgz
NetBSD 9.0powerpcrpm2cpio-1.3nb6.tgz
NetBSD 9.0sh3elrpm2cpio-1.3nb6.tgz
NetBSD 9.0sh3elrpm2cpio-1.3nb5.tgz
NetBSD 9.0sh3elrpm2cpio-1.3nb5.tgz
NetBSD 9.0sh3elrpm2cpio-1.3nb6.tgz
NetBSD 9.0sparc64rpm2cpio-1.3nb6.tgz
NetBSD 9.0sparc64rpm2cpio-1.3nb5.tgz
NetBSD 9.0sparc64rpm2cpio-1.3nb6.tgz
NetBSD 9.0sparcrpm2cpio-1.3nb6.tgz
NetBSD 9.0sparcrpm2cpio-1.3nb5.tgz
NetBSD 9.0sparcrpm2cpio-1.3nb5.tgz
NetBSD 9.0sparcrpm2cpio-1.3nb5.tgz
NetBSD 9.0sparcrpm2cpio-1.3nb6.tgz
NetBSD 9.0vaxrpm2cpio-1.3nb5.tgz
NetBSD 9.0vaxrpm2cpio-1.3nb5.tgz
NetBSD 9.0vaxrpm2cpio-1.3nb6.tgz
NetBSD 9.0vaxrpm2cpio-1.3nb6.tgz
NetBSD 9.0x86_64rpm2cpio-1.3nb6.tgz
NetBSD 9.0x86_64rpm2cpio-1.3nb6.tgz
NetBSD 9.0x86_64rpm2cpio-1.3nb5.tgz
NetBSD 9.0x86_64rpm2cpio-1.3nb6.tgz
NetBSD 9.0x86_64rpm2cpio-1.3nb6.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.