converters/p5-nkf - The NetBSD Packages Collection

Perl library for Network Kanji code conversion Filter

Nkf is a yet another kanji code converter among networks, hosts and terminals.
It converts input kanji code to desig- nated kanji code such as 7-bit
JIS, MS-kanji (shifted-JIS) or EUC.

One of the most unique facility of nkf is the guess of the input kanji
code. It currently recognizes 7-bit JIS, MS- kanji (shifted-JIS) and EUC.
So users needn't the input kanji code specification.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-nkf-2.15nb3.tgz
NetBSD 8.0earmv7hfp5-nkf-2.15nb2.tgz
NetBSD 8.0earmv7hfp5-nkf-2.15nb3.tgz
NetBSD 8.0i386p5-nkf-2.15nb2.tgz
NetBSD 8.0i386p5-nkf-2.15nb3.tgz
NetBSD 8.0powerpcp5-nkf-2.15nb2.tgz
NetBSD 8.0powerpcp5-nkf-2.15nb3.tgz
NetBSD 8.0powerpcp5-nkf-2.15nb3.tgz
NetBSD 8.0powerpcp5-nkf-2.15nb3.tgz
NetBSD 8.0x86_64p5-nkf-2.15nb2.tgz
NetBSD 8.0x86_64p5-nkf-2.15nb3.tgz
NetBSD 9.0aarch64p5-nkf-2.15nb3.tgz
NetBSD 9.0aarch64p5-nkf-2.15nb2.tgz
NetBSD 9.0aarch64p5-nkf-2.15nb3.tgz
NetBSD 9.0alphap5-nkf-2.15nb3.tgz
NetBSD 9.0alphap5-nkf-2.15nb2.tgz
NetBSD 9.0alphap5-nkf-2.15nb3.tgz
NetBSD 9.0earmp5-nkf-2.15nb2.tgz
NetBSD 9.0earmp5-nkf-2.15nb3.tgz
NetBSD 9.0earmp5-nkf-2.15nb3.tgz
NetBSD 9.0earmv6hfp5-nkf-2.15nb3.tgz
NetBSD 9.0earmv6hfp5-nkf-2.15nb2.tgz
NetBSD 9.0earmv6hfp5-nkf-2.15nb3.tgz
NetBSD 9.0earmv7hfp5-nkf-2.15nb3.tgz
NetBSD 9.0earmv7hfp5-nkf-2.15nb2.tgz
NetBSD 9.0earmv7hfp5-nkf-2.15nb3.tgz
NetBSD 9.0earmv7hfp5-nkf-2.15nb3.tgz
NetBSD 9.0i386p5-nkf-2.15nb2.tgz
NetBSD 9.0i386p5-nkf-2.15nb3.tgz
NetBSD 9.0i386p5-nkf-2.15nb3.tgz
NetBSD 9.0mips64ebp5-nkf-2.15nb3.tgz
NetBSD 9.0mips64ebp5-nkf-2.15nb2.tgz
NetBSD 9.0mips64ebp5-nkf-2.15nb2.tgz
NetBSD 9.0mips64ebp5-nkf-2.15nb2.tgz
NetBSD 9.0mips64ebp5-nkf-2.15nb3.tgz
NetBSD 9.0mipselp5-nkf-2.15nb3.tgz
NetBSD 9.0mipselp5-nkf-2.15nb2.tgz
NetBSD 9.0mipselp5-nkf-2.15nb2.tgz
NetBSD 9.0mipselp5-nkf-2.15nb3.tgz
NetBSD 9.0powerpcp5-nkf-2.15nb3.tgz
NetBSD 9.0powerpcp5-nkf-2.15nb2.tgz
NetBSD 9.0powerpcp5-nkf-2.15nb3.tgz
NetBSD 9.0powerpcp5-nkf-2.15nb3.tgz
NetBSD 9.0sh3elp5-nkf-2.15nb3.tgz
NetBSD 9.0sh3elp5-nkf-2.15nb2.tgz
NetBSD 9.0sh3elp5-nkf-2.15nb2.tgz
NetBSD 9.0sh3elp5-nkf-2.15nb3.tgz
NetBSD 9.0sparc64p5-nkf-2.15nb3.tgz
NetBSD 9.0sparc64p5-nkf-2.15nb2.tgz
NetBSD 9.0sparc64p5-nkf-2.15nb3.tgz
NetBSD 9.0sparcp5-nkf-2.15nb3.tgz
NetBSD 9.0sparcp5-nkf-2.15nb2.tgz
NetBSD 9.0sparcp5-nkf-2.15nb2.tgz
NetBSD 9.0sparcp5-nkf-2.15nb2.tgz
NetBSD 9.0sparcp5-nkf-2.15nb3.tgz
NetBSD 9.0vaxp5-nkf-2.15nb2.tgz
NetBSD 9.0vaxp5-nkf-2.15nb2.tgz
NetBSD 9.0vaxp5-nkf-2.15nb3.tgz
NetBSD 9.0vaxp5-nkf-2.15nb3.tgz
NetBSD 9.0x86_64p5-nkf-2.15nb3.tgz
NetBSD 9.0x86_64p5-nkf-2.15nb3.tgz
NetBSD 9.0x86_64p5-nkf-2.15nb2.tgz
NetBSD 9.0x86_64p5-nkf-2.15nb3.tgz
NetBSD 9.0x86_64p5-nkf-2.15nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.