converters/p5-MIME-Base64-URLSafe - The NetBSD Packages Collection

Perl version of Python's URL-safe base64 codec

This module is a perl version of python's URL-safe base64 encoder
/ decoder.

When embedding binary data in URL, it is preferable to use base64
encoding. However, two characters ('+' and '/') used in the standard
base64 encoding have special meanings in URLs, often leading to
re-encoding with URL-encoding, or worse, interoperability problems.

To overcome the problem, the module provides a variation of base64
codec compatible with python's urlsafe_b64encode / urlsafe_b64decode.

Modification rules from base64:

    use '-' and '_' instead of '+' and '/'
    no line feeds
    no trailing equals (=)

Build dependencies

pkgtools/cwrappers

Runtime dependencies

lang/perl5 lang/perl5

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 8.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 8.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 8.0i386p5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 8.0i386p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 8.0powerpcp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 8.0powerpcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 8.0powerpcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 8.0powerpcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 8.0x86_64p5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 8.0x86_64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0aarch64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0aarch64p5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0aarch64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0alphap5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0alphap5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0alphap5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0earmp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmv6hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmv6hfp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0earmv6hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0earmv7hfp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0i386p5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0i386p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0mips64ebp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0mips64ebp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0mips64ebp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0mips64ebp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0mips64ebp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0powerpcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0powerpcp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0powerpcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0powerpcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0sparc64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0sparc64p5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0sparc64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0sparcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0sparcp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0sparcp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0sparcp5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0sparcp5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0x86_64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0x86_64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0x86_64p5-MIME-Base64-URLSafe-0.01nb12.tgz
NetBSD 9.0x86_64p5-MIME-Base64-URLSafe-0.01nb13.tgz
NetBSD 9.0x86_64p5-MIME-Base64-URLSafe-0.01nb13.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.