cad/gnetman - The NetBSD Packages Collection

Advanced Netlister and Netlist Manipulation Database for gEDA

gnetman is a program which currently supports advanced SPICE
netlisting from gschem (part of the gEDA tool suite). The
primary use so far has been for complex IC design.  Supported
features include multi-level hierarchy, instance arrays, and
buses. If you're just doing flat designs for PC boards or
smaller SPICE simulations, the usual path is to use the spice-sdb
netlister for gnetlist instead.

The long term goal of gnetman is far greater. Two projects under
consideration include a schematic generator, and a technology
mapping back-end for Icarus Verilog. Basically, gnetman is a
netlist manipulation database well suited for low-level
manipulation of netlists.

Build dependencies

x11/xorgproto x11/xcb-proto pkgtools/cwrappers

Runtime dependencies

lang/tcl x11/tk lang/tcl x11/tk

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 8.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 8.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 8.0i386gnetman-20050211nb8.tgz
NetBSD 8.0i386gnetman-20050211nb8.tgz
NetBSD 8.0powerpcgnetman-20050211nb8.tgz
NetBSD 8.0powerpcgnetman-20050211nb8.tgz
NetBSD 8.0powerpcgnetman-20050211nb8.tgz
NetBSD 8.0powerpcgnetman-20050211nb8.tgz
NetBSD 8.0x86_64gnetman-20050211nb8.tgz
NetBSD 8.0x86_64gnetman-20050211nb8.tgz
NetBSD 9.0aarch64gnetman-20050211nb8.tgz
NetBSD 9.0aarch64gnetman-20050211nb8.tgz
NetBSD 9.0aarch64gnetman-20050211nb8.tgz
NetBSD 9.0alphagnetman-20050211nb8.tgz
NetBSD 9.0alphagnetman-20050211nb8.tgz
NetBSD 9.0alphagnetman-20050211nb8.tgz
NetBSD 9.0earmv6hfgnetman-20050211nb8.tgz
NetBSD 9.0earmv6hfgnetman-20050211nb8.tgz
NetBSD 9.0earmv6hfgnetman-20050211nb8.tgz
NetBSD 9.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 9.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 9.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 9.0earmv7hfgnetman-20050211nb8.tgz
NetBSD 9.0i386gnetman-20050211nb8.tgz
NetBSD 9.0i386gnetman-20050211nb8.tgz
NetBSD 9.0mips64ebgnetman-20050211nb8.tgz
NetBSD 9.0mips64ebgnetman-20050211nb8.tgz
NetBSD 9.0mips64ebgnetman-20050211nb8.tgz
NetBSD 9.0mips64ebgnetman-20050211nb8.tgz
NetBSD 9.0mips64ebgnetman-20050211nb8.tgz
NetBSD 9.0powerpcgnetman-20050211nb8.tgz
NetBSD 9.0powerpcgnetman-20050211nb8.tgz
NetBSD 9.0powerpcgnetman-20050211nb8.tgz
NetBSD 9.0powerpcgnetman-20050211nb8.tgz
NetBSD 9.0sparc64gnetman-20050211nb8.tgz
NetBSD 9.0sparc64gnetman-20050211nb8.tgz
NetBSD 9.0sparc64gnetman-20050211nb8.tgz
NetBSD 9.0sparcgnetman-20050211nb8.tgz
NetBSD 9.0sparcgnetman-20050211nb8.tgz
NetBSD 9.0sparcgnetman-20050211nb8.tgz
NetBSD 9.0sparcgnetman-20050211nb8.tgz
NetBSD 9.0sparcgnetman-20050211nb8.tgz
NetBSD 9.0x86_64gnetman-20050211nb8.tgz
NetBSD 9.0x86_64gnetman-20050211nb8.tgz
NetBSD 9.0x86_64gnetman-20050211nb8.tgz
NetBSD 9.0x86_64gnetman-20050211nb8.tgz
NetBSD 9.0x86_64gnetman-20050211nb8.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.