archivers/xz - The NetBSD Packages Collection

General-purpose data compression software

LZMA is a general purporse compression algorithm designed by Igor
Pavlov as part of 7-Zip. It provides high compression ratio while
keeping the decompression speed fast.

XZ Utils are an attempt to make LZMA compression easy to use on
free (as in freedom) operating systems. This is achieved by providing
tools and libraries which are similar to use than the equivalents
of the most popular existing compression algorithms.

XZ Utils consist of a few relatively separate parts:
  * liblzma is an encoder/decoder library with support for several
    filters (algorithm implementations). The primary filter is
    LZMA.
  * libzfile (or whatever the name will be) enables reading from
    and writing to gzip, bzip2 and LZMA compressed and uncompressed
    files with an API similar to the standard ANSI-C file I/O.
    [ NOTE: libzfile is not implemented yet. ]
  * xz command line tool has almost identical syntax than gzip
    and bzip2. It makes LZMA easy for average users, but also
    provides advanced options to finetune the compression settings.
  * A few shell scripts make diffing and grepping LZMA compressed
    files easy. The scripts were adapted from gzip and bzip2.

Build dependencies

devel/libtool-base pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfxz-5.2.5.tgz
NetBSD 8.0i386xz-5.2.5.tgz
NetBSD 8.0i386xz-5.2.5nb1.tgz
NetBSD 8.0powerpcxz-5.2.5.tgz
NetBSD 8.0powerpcxz-5.2.5.tgz
NetBSD 8.0x86_64xz-5.2.5nb1.tgz
NetBSD 8.0x86_64xz-5.2.5.tgz
NetBSD 9.0aarch64xz-5.2.5nb1.tgz
NetBSD 9.0aarch64xz-5.2.5.tgz
NetBSD 9.0alphaxz-5.2.5.tgz
NetBSD 9.0alphaxz-5.2.5.tgz
NetBSD 9.0alphaxz-5.2.5nb1.tgz
NetBSD 9.0earmxz-5.2.5.tgz
NetBSD 9.0earmxz-5.2.5.tgz
NetBSD 9.0earmxz-5.2.5nb1.tgz
NetBSD 9.0earmv4xz-5.2.5nb1.tgz
NetBSD 9.0earmv6hfxz-5.2.5nb1.tgz
NetBSD 9.0earmv6hfxz-5.2.5.tgz
NetBSD 9.0earmv7hfxz-5.2.5.tgz
NetBSD 9.0earmv7hfxz-5.2.5nb1.tgz
NetBSD 9.0i386xz-5.2.5nb1.tgz
NetBSD 9.0i386xz-5.2.5.tgz
NetBSD 9.0i386xz-5.2.5nb1.tgz
NetBSD 9.0m68kxz-5.2.5.tgz
NetBSD 9.0m68kxz-5.2.5.tgz
NetBSD 9.0mips64ebxz-5.2.5.tgz
NetBSD 9.0mips64ebxz-5.2.5.tgz
NetBSD 9.0mips64ebxz-5.2.5nb1.tgz
NetBSD 9.0mipselxz-5.2.5.tgz
NetBSD 9.0mipselxz-5.2.5.tgz
NetBSD 9.0mipselxz-5.2.5.tgz
NetBSD 9.0powerpcxz-5.2.5.tgz
NetBSD 9.0powerpcxz-5.2.5.tgz
NetBSD 9.0sh3elxz-5.2.5.tgz
NetBSD 9.0sh3elxz-5.2.5.tgz
NetBSD 9.0sh3elxz-5.2.5nb1.tgz
NetBSD 9.0sparc64xz-5.2.5.tgz
NetBSD 9.0sparc64xz-5.2.5.tgz
NetBSD 9.0sparc64xz-5.2.5nb1.tgz
NetBSD 9.0sparcxz-5.2.5.tgz
NetBSD 9.0sparcxz-5.2.5.tgz
NetBSD 9.0sparcxz-5.2.5.tgz
NetBSD 9.0sparcxz-5.2.5nb1.tgz
NetBSD 9.0vaxxz-5.2.5.tgz
NetBSD 9.0vaxxz-5.2.5.tgz
NetBSD 9.0vaxxz-5.2.5nb1.tgz
NetBSD 9.0x86_64xz-5.2.5nb1.tgz
NetBSD 9.0x86_64xz-5.2.5nb1.tgz
NetBSD 9.0x86_64xz-5.2.5nb1.tgz
NetBSD 9.0x86_64xz-5.2.5.tgz
NetBSD 9.0x86_64xz-5.2.5.tgz
NetBSD 9.0x86_64xz-5.2.5nb1.tgz
NetBSD 9.99.96aarch64ebxz-5.2.5.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

nls
Use native language support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.