archivers/upx - The NetBSD Packages Collection

Ultimate packer for executables

UPX is a free, portable, extendable, high-performance executable packer for
several different executable formats. It achieves an excellent compression
ratio and offers very fast decompression. Your executables suffer no memory
overhead or other drawbacks because of in-place decompression.

Build dependencies

pkgtools/mktools devel/gmake lang/perl5 pkgtools/cwrappers

Runtime dependencies

devel/ucl devel/ucl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfupx-3.96nb2.tgz
NetBSD 8.0i386upx-3.96nb2.tgz
NetBSD 8.0i386upx-3.96nb2.tgz
NetBSD 8.0powerpcupx-3.96nb2.tgz
NetBSD 8.0powerpcupx-3.96nb2.tgz
NetBSD 8.0x86_64upx-3.96nb2.tgz
NetBSD 8.0x86_64upx-3.96nb2.tgz
NetBSD 9.0aarch64upx-3.96nb2.tgz
NetBSD 9.0aarch64upx-3.96nb2.tgz
NetBSD 9.0alphaupx-3.96nb2.tgz
NetBSD 9.0alphaupx-3.96nb2.tgz
NetBSD 9.0alphaupx-3.96nb2.tgz
NetBSD 9.0earmupx-3.96nb2.tgz
NetBSD 9.0earmupx-3.96nb2.tgz
NetBSD 9.0earmv6hfupx-3.96nb2.tgz
NetBSD 9.0earmv6hfupx-3.96nb2.tgz
NetBSD 9.0earmv7hfupx-3.96nb2.tgz
NetBSD 9.0earmv7hfupx-3.96nb2.tgz
NetBSD 9.0i386upx-3.96nb2.tgz
NetBSD 9.0i386upx-3.96nb2.tgz
NetBSD 9.0i386upx-3.96nb2.tgz
NetBSD 9.0mips64ebupx-3.96nb2.tgz
NetBSD 9.0mips64ebupx-3.96nb2.tgz
NetBSD 9.0mips64ebupx-3.96nb2.tgz
NetBSD 9.0powerpcupx-3.96nb2.tgz
NetBSD 9.0powerpcupx-3.96nb2.tgz
NetBSD 9.0sparc64upx-3.96nb2.tgz
NetBSD 9.0sparc64upx-3.96nb2.tgz
NetBSD 9.0sparc64upx-3.96nb2.tgz
NetBSD 9.0sparcupx-3.96nb2.tgz
NetBSD 9.0sparcupx-3.96nb2.tgz
NetBSD 9.0x86_64upx-3.96nb3.tgz
NetBSD 9.0x86_64upx-3.96nb2.tgz
NetBSD 9.0x86_64upx-3.96nb2.tgz
NetBSD 9.0x86_64upx-3.96nb2.tgz
NetBSD 9.0x86_64upx-3.96nb2.tgz
NetBSD 9.0x86_64upx-3.96nb3.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.