archivers/py-zipp1 - The NetBSD Packages Collection

Backport of pathlib-compatible object wrapper for zip files (for Python 2.x)

A pathlib-compatible Zipfile object wrapper. A backport of the Path
object.

This package contains the last Python 2.x compatible version.

Build dependencies

devel/py-setuptools_scm5 devel/py-setuptools44 pkgtools/mktools pkgtools/cwrappers

Runtime dependencies

devel/py-contextlib2 lang/python27 lang/python27

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfpy27-zipp-1.2.0.tgz
NetBSD 8.0earmv7hfpy36-zipp-1.2.0.tgz
NetBSD 8.0earmv7hfpy37-zipp-1.2.0.tgz
NetBSD 8.0earmv7hfpy38-zipp-1.2.0.tgz
NetBSD 8.0earmv7hfpy39-zipp-1.2.0.tgz
NetBSD 8.0i386py27-zipp-1.2.0nb1.tgz
NetBSD 8.0i386py27-zipp-1.2.0nb1.tgz
NetBSD 8.0powerpcpy27-zipp-1.2.0.tgz
NetBSD 8.0powerpcpy27-zipp-1.2.0.tgz
NetBSD 8.0powerpcpy310-zipp-1.2.0.tgz
NetBSD 8.0powerpcpy36-zipp-1.2.0.tgz
NetBSD 8.0powerpcpy37-zipp-1.2.0.tgz
NetBSD 8.0powerpcpy38-zipp-1.2.0.tgz
NetBSD 8.0powerpcpy39-zipp-1.2.0.tgz
NetBSD 8.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 8.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0aarch64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0aarch64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0alphapy27-zipp-1.2.0.tgz
NetBSD 9.0alphapy310-zipp-1.2.0.tgz
NetBSD 9.0alphapy36-zipp-1.2.0.tgz
NetBSD 9.0alphapy37-zipp-1.2.0.tgz
NetBSD 9.0alphapy38-zipp-1.2.0.tgz
NetBSD 9.0alphapy39-zipp-1.2.0.tgz
NetBSD 9.0alphapy27-zipp-1.2.0nb1.tgz
NetBSD 9.0alphapy27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmpy27-zipp-1.2.0.tgz
NetBSD 9.0earmpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmv4py27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmv4py27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmv6hfpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmv6hfpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmv7hfpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0earmv7hfpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0i386py27-zipp-1.2.0nb1.tgz
NetBSD 9.0i386py27-zipp-1.2.0nb1.tgz
NetBSD 9.0i386py27-zipp-1.2.0nb1.tgz
NetBSD 9.0m68kpy27-zipp-1.2.0.tgz
NetBSD 9.0m68kpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0m68kpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0mips64ebpy27-zipp-1.2.0.tgz
NetBSD 9.0mips64ebpy310-zipp-1.2.0.tgz
NetBSD 9.0mips64ebpy36-zipp-1.2.0.tgz
NetBSD 9.0mips64ebpy37-zipp-1.2.0.tgz
NetBSD 9.0mips64ebpy38-zipp-1.2.0.tgz
NetBSD 9.0mips64ebpy39-zipp-1.2.0.tgz
NetBSD 9.0mips64ebpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0mips64ebpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0mipselpy27-zipp-1.2.0.tgz
NetBSD 9.0mipselpy27-zipp-1.2.0.tgz
NetBSD 9.0mipselpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0mipselpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0powerpcpy27-zipp-1.2.0.tgz
NetBSD 9.0powerpcpy27-zipp-1.2.0.tgz
NetBSD 9.0powerpcpy36-zipp-1.2.0.tgz
NetBSD 9.0powerpcpy37-zipp-1.2.0.tgz
NetBSD 9.0powerpcpy38-zipp-1.2.0.tgz
NetBSD 9.0powerpcpy39-zipp-1.2.0.tgz
NetBSD 9.0sh3elpy27-zipp-1.2.0.tgz
NetBSD 9.0sh3elpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0sh3elpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0sparc64py27-zipp-1.2.0.tgz
NetBSD 9.0sparc64py310-zipp-1.2.0.tgz
NetBSD 9.0sparc64py36-zipp-1.2.0.tgz
NetBSD 9.0sparc64py37-zipp-1.2.0.tgz
NetBSD 9.0sparc64py38-zipp-1.2.0.tgz
NetBSD 9.0sparc64py39-zipp-1.2.0.tgz
NetBSD 9.0sparc64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0sparc64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0sparcpy27-zipp-1.2.0.tgz
NetBSD 9.0sparcpy36-zipp-1.2.0.tgz
NetBSD 9.0sparcpy37-zipp-1.2.0.tgz
NetBSD 9.0sparcpy38-zipp-1.2.0.tgz
NetBSD 9.0sparcpy39-zipp-1.2.0.tgz
NetBSD 9.0sparcpy27-zipp-1.2.0.tgz
NetBSD 9.0sparcpy36-zipp-1.2.0.tgz
NetBSD 9.0sparcpy37-zipp-1.2.0.tgz
NetBSD 9.0sparcpy38-zipp-1.2.0.tgz
NetBSD 9.0sparcpy39-zipp-1.2.0.tgz
NetBSD 9.0sparcpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0sparcpy27-zipp-1.2.0nb1.tgz
NetBSD 9.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.0x86_64py27-zipp-1.2.0nb1.tgz
NetBSD 9.99.96aarch64ebpy27-zipp-1.2.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.