archivers/lziprecover - The NetBSD Packages Collection

Recovery tool for lossless data compressor based on the LZMA algorithm

Lziprecover is a data recovery tool and decompressor for files in the
lzip compressed data format (.lz) able to repair slightly damaged files,
recover badly damaged files from two or more copies, extract undamaged
members from multi-member files, decompress files and test integrity of
files.

Lziprecover is able to recover or decompress files produced by any of
the compressors in the lzip family; lzip, plzip, minilzip/lzlib, clzip
and pdlzip. This recovery capability contributes to make the lzip format
one of the best options for long-term data archiving.

Lziprecover is able to efficiently extract a range of bytes from a
multi-member file, because it only decompresses the members containing
the desired data.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

(none)

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hflziprecover-1.22.tgz
NetBSD 8.0earmv7hflziprecover-1.22.tgz
NetBSD 8.0earmv7hflziprecover-1.22.tgz
NetBSD 8.0i386lziprecover-1.22.tgz
NetBSD 8.0i386lziprecover-1.22.tgz
NetBSD 8.0powerpclziprecover-1.22.tgz
NetBSD 8.0powerpclziprecover-1.22.tgz
NetBSD 8.0powerpclziprecover-1.22.tgz
NetBSD 8.0powerpclziprecover-1.22.tgz
NetBSD 8.0x86_64lziprecover-1.22.tgz
NetBSD 8.0x86_64lziprecover-1.22.tgz
NetBSD 9.0aarch64lziprecover-1.22.tgz
NetBSD 9.0aarch64lziprecover-1.22.tgz
NetBSD 9.0aarch64lziprecover-1.22.tgz
NetBSD 9.0alphalziprecover-1.22.tgz
NetBSD 9.0alphalziprecover-1.22.tgz
NetBSD 9.0alphalziprecover-1.22.tgz
NetBSD 9.0earmlziprecover-1.22.tgz
NetBSD 9.0earmlziprecover-1.22.tgz
NetBSD 9.0earmlziprecover-1.22.tgz
NetBSD 9.0earmv6hflziprecover-1.22.tgz
NetBSD 9.0earmv6hflziprecover-1.22.tgz
NetBSD 9.0earmv6hflziprecover-1.22.tgz
NetBSD 9.0earmv7hflziprecover-1.22.tgz
NetBSD 9.0earmv7hflziprecover-1.22.tgz
NetBSD 9.0earmv7hflziprecover-1.22.tgz
NetBSD 9.0earmv7hflziprecover-1.22.tgz
NetBSD 9.0i386lziprecover-1.22.tgz
NetBSD 9.0i386lziprecover-1.22.tgz
NetBSD 9.0i386lziprecover-1.22.tgz
NetBSD 9.0mips64eblziprecover-1.22.tgz
NetBSD 9.0mips64eblziprecover-1.21.tgz
NetBSD 9.0mips64eblziprecover-1.21.tgz
NetBSD 9.0mips64eblziprecover-1.22.tgz
NetBSD 9.0mips64eblziprecover-1.22.tgz
NetBSD 9.0powerpclziprecover-1.22.tgz
NetBSD 9.0powerpclziprecover-1.22.tgz
NetBSD 9.0powerpclziprecover-1.22.tgz
NetBSD 9.0powerpclziprecover-1.22.tgz
NetBSD 9.0sparc64lziprecover-1.22.tgz
NetBSD 9.0sparc64lziprecover-1.22.tgz
NetBSD 9.0sparc64lziprecover-1.22.tgz
NetBSD 9.0sparclziprecover-1.22.tgz
NetBSD 9.0sparclziprecover-1.21.tgz
NetBSD 9.0sparclziprecover-1.21.tgz
NetBSD 9.0sparclziprecover-1.22.tgz
NetBSD 9.0sparclziprecover-1.22.tgz
NetBSD 9.0vaxlziprecover-1.22.tgz
NetBSD 9.0vaxlziprecover-1.22.tgz
NetBSD 9.0vaxlziprecover-1.22.tgz
NetBSD 9.0x86_64lziprecover-1.22.tgz
NetBSD 9.0x86_64lziprecover-1.22.tgz
NetBSD 9.0x86_64lziprecover-1.22.tgz
NetBSD 9.0x86_64lziprecover-1.22.tgz
NetBSD 9.0x86_64lziprecover-1.22.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.