archivers/file-roller - The NetBSD Packages Collection

Archive manager for the GNOME desktop environment

File Roller is an archive manager for the GNOME environment.  This means
that you can create and modify archives; view the content of an archive;
view and modify a file contained in the archive; extract files from the
archive.

Build dependencies

pkgtools/x11-links x11/xorgproto x11/xcb-proto devel/meson devel/glib2-tools lang/python310 pkgtools/mktools textproc/itstool devel/gettext-tools devel/pkgconf pkgtools/cwrappers

Runtime dependencies

devel/glib2 graphics/hicolor-icon-theme sysutils/libnotify textproc/json-glib x11/gtk3 devel/glib2 graphics/hicolor-icon-theme sysutils/libnotify textproc/json-glib x11/gtk3

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hffile-roller-3.38.0.tgz
NetBSD 8.0i386file-roller-3.38.0nb1.tgz
NetBSD 8.0i386file-roller-3.38.0nb1.tgz
NetBSD 8.0powerpcfile-roller-3.38.0.tgz
NetBSD 8.0powerpcfile-roller-3.38.0nb1.tgz
NetBSD 8.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 8.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 9.0aarch64file-roller-3.38.0nb1.tgz
NetBSD 9.0aarch64file-roller-3.38.0nb1.tgz
NetBSD 9.0alphafile-roller-3.38.0nb1.tgz
NetBSD 9.0alphafile-roller-3.38.0nb1.tgz
NetBSD 9.0alphafile-roller-3.38.0nb1.tgz
NetBSD 9.0earmfile-roller-3.38.0nb1.tgz
NetBSD 9.0earmfile-roller-3.38.0nb1.tgz
NetBSD 9.0earmfile-roller-3.38.0nb1.tgz
NetBSD 9.0earmv6hffile-roller-3.38.0nb1.tgz
NetBSD 9.0earmv6hffile-roller-3.38.0nb1.tgz
NetBSD 9.0earmv7hffile-roller-3.38.0nb1.tgz
NetBSD 9.0earmv7hffile-roller-3.38.0nb1.tgz
NetBSD 9.0i386file-roller-3.38.0nb1.tgz
NetBSD 9.0i386file-roller-3.38.0nb1.tgz
NetBSD 9.0i386file-roller-3.38.0nb1.tgz
NetBSD 9.0mips64ebfile-roller-3.38.0nb1.tgz
NetBSD 9.0mips64ebfile-roller-3.38.0nb1.tgz
NetBSD 9.0mips64ebfile-roller-3.38.0nb1.tgz
NetBSD 9.0powerpcfile-roller-3.38.0nb1.tgz
NetBSD 9.0powerpcfile-roller-3.38.0.tgz
NetBSD 9.0sparc64file-roller-3.38.0nb1.tgz
NetBSD 9.0sparc64file-roller-3.38.0nb1.tgz
NetBSD 9.0sparc64file-roller-3.38.0nb1.tgz
NetBSD 9.0sparcfile-roller-3.38.0.tgz
NetBSD 9.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 9.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 9.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 9.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 9.0x86_64file-roller-3.38.0nb1.tgz
NetBSD 9.0x86_64file-roller-3.38.0nb2.tgz
NetBSD 9.99.96aarch64ebfile-roller-3.38.0nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.